Lexus IS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
243 Posts
Discussion Starter #1
Problem: The boost sensor is not accurate. I tested it against 2 other brands on the same vacuum line and it seems the Zeitronix reads -3 psi under as compared and jumps around in real time (milliseconds), even with when trying a tiny orifice to stabilize.

Too bad... since it would be nice to get that info on a flush mounted lcd.

Anybody else try this product with similar results? I have not had a response from them yet............

:pissed:
 

·
Registered
Joined
·
3,398 Posts
Well that kinda sucks, i just bought the Zeitronix wideband + LCD display off of ebay, and i was about to buy the sensor from their website. Can you use another brand sensor or is the Zeitronix sensor the only one? Anybody else have problems with it?
 

·
Registered
Joined
·
7,122 Posts
I'm not using the boost portion of my Zeitronix either, I'm used the Analog type gauge, not the digital gauge. Thats just my preference..
 

·
Registered
Joined
·
3,398 Posts
nobody else has experience with this boost sensor? i have already ordered the zeitronix and i'm wondering if i should get the sensor or get one from AEM etc.. if it would work.
 

·
Guru of Supercharged ISs
Joined
·
8,744 Posts
yes,


yes it IS crap.


many of us have had NOTHIGN but trouble with it... long story but mine never was installed & then they said i fuked it uop &wouldnt replace it or refund me


IF it ever reads correctly it reads so fast you can never actually see what you hit unless you use the Peak button to see after the run...

total bullshit.. i will never deal with them again.. .thank god the Wideband & EGT work fine &

I will use a Nexus Autometer Boost gauge.
 
1 - 5 of 5 Posts
Top