Lexus IS Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
278 Posts
Discussion Starter #1
I have been reading through several of these forums and there was different opinions on what kind of subs are best. I currently have a Kicker KX200.2 Amp that is bridged to a 10" Kicker Comp. It gives a punch but not as quite as hard as I would like to feel it. Considering the amp and sub I have now... I don't know if I should get another 10" or one 12" or two 12"s?? My brother has two 12" Kicker L7s and those I can feel but in one of the forums I read that the L7s are not that good. What's the best setup for the clean and feel of bass on a tight budget??
 

·
Registered
Joined
·
159 Posts
go with 1 12" alumapro alchemy RX. There is one on ebay right now that could go for under 200. That sub will amaze you.
 

·
Registered
Joined
·
262 Posts
200 W isn't that much to get a lot of hard hitting bass, your sub doesn't have the balls either, I mean 125 RMS?. Try upgrading your amp first. You might find that your subs has alot more then you thought. Try running the 400.2 from Kicker (I am not a fan of Kicker but if you are, more power to ya.) If you sub goes out (It will), get a CompVR 12, much better power handling. Then you will feel some punch.

If you read my post and thought (what a looney! he's telling me to purposely blow my sub!) Yup I am, cause the sound you get right now is about all you'll get. Or you could sell it.... But it's always cool to have a smoke machine in your car...

But if you want to switch to better brands (and better quality)... Alpine, JL, PPI, PG, HiFonics (lisnup) etc. Get some Alumapro or even JL subs.
 

·
Registered
Joined
·
125 Posts
I have 2 Kicker 12L7's in a sealed box facing the rear of the car. I have a Rockford Fosgate Power 1000.2 at 4 ohms running them and the hit hard and clean. My freinds can hear me coming from about 4-5 blocks away. It makes my roof flex when my sunroof is open.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #10
rockford amp with two 12" kickers is the same setup my brother has. but uh hey how do you know if your SUB blows other than it stopping? could you open it up and check it? and what do you do when it blows.. return, repair, or is it garbage? cause i think i just blew my kicker comp 10" with the kicker 200w amp. it just stopped in the middle of a song but the amp is still working properly. any ideas?
 

·
Registered
Joined
·
125 Posts
An amp might turn on but not prodeuce any power if the power devices inside the amp go bad. Most likely this is the case and you can send it back to Kicker for a repair. Most of the time they will not charge you if you send it directly to them. Atleast, I have never paid to have any Rockford amps fixed.
 

·
Registered
Joined
·
125 Posts
Well, is it a dual voice coil or single? I have found most speakers still make some sound when blown. You can unhook the sub from the amp and us a battery to check if the sub still pulls itself inwards. If it does, then it is wired correct and the voice coils are working. Can you hook another speaker up to the amp?
 

·
Registered
Joined
·
278 Posts
Discussion Starter #14
It's a 10" 4-ohm Component Subwoofer. It's not a dual voice coil. I hooked up a home stereo speaker to the amp and it give off power to that speaker so the amp is still working. It's the sub that is not working. It gives off no noise at all. How and what battery do you use to check the sub?
 

·
Registered
Joined
·
125 Posts
You can use some speaker wire, hook up on end like normal to the speaker. Then hold the negative wire to the negative side of a d size battery. Touch the positive wire to the positve side of the battery, if it pulls in, then everything is correct. This is how I check a box after I have everything hooked up. Then I know if I have a speaker out of phase or not.
 

·
Registered
Joined
·
975 Posts
daily8260 said:
It's a 10" 4-ohm Component Subwoofer. It's not a dual voice coil. I hooked up a home stereo speaker to the amp and it give off power to that speaker so the amp is still working. It's the sub that is not working. It gives off no noise at all. How and what battery do you use to check the sub?
If that is what you did, you can then do the opposite:

Hook up your sub to your home amp/reciever and see what happends. Don't worry about the sub being a 4 ohm if your home amp is only rated down to 8. Just play it for a long enough to see if it is blown (shouldn't tkae more than a few seconds) and you won't even come close to damaging the amp.

Or, you can hook the sub up to your satellite/main spk's amp to see what's up.

Or, a crude way to check out your sub, simply place just a bit of pressure on the cone w/your hands, to push it slowly in and out. See if it feels like it's stuck or feels like it's not traveling smoothly and try to hear if it sounds scratchy as it travel. If it does to any of the above, it' blown (especially if it feels like it's nt moving - then you've fried the voice coil). It should travel freely w/o any scratchy sounds.
 

·
Registered
Joined
·
278 Posts
Discussion Starter #17
I hooked it up to my home stereo system and I got nothing from the sub. :( I did what you said and placed pressure on the cone and it moved smoothly without any scratches. What should I do now?
 

·
Registered
Joined
·
278 Posts
Discussion Starter #18
I think I found what the problem was. I opened up the sub and within the sub one of the wires connected to the cone itself got disconnected from another wire.. probably got disconnected because of the vibrations and extreme movement of the cone. I hope it will work after I somehow reglue it or something. Thanks for all the help!
 

·
Registered
Joined
·
975 Posts
daily8260 said:
I think I found what the problem was. I opened up the sub and within the sub one of the wires connected to the cone itself got disconnected from another wire.. probably got disconnected because of the vibrations and extreme movement of the cone. I hope it will work after I somehow reglue it or something. Thanks for all the help!
Glad you figured it out!

So, were you able to solder the wire back on? Does it work now?
 
1 - 20 of 21 Posts
Top