Lexus IS Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I'm driving a 98' Mkiv supra.. seems that i have the same engine as you guys do :chill:. The real deal is, i hit something on the highway and now my mid pipe has a big hole in it. So I'm looking to replace it. So I drove down to Boostlogic here in austin, and they guy there told me that their mid-pipe fits both twin and nonturbo supras. So I decided to buy it. Turns out, it doesnt. So i figure it has to do with the 98 setup.. When i got to installing the midpipe i noticed that the bolt setup coming out of my headers is much different then the setup on my new midpipe. Heres a pic of the midpipe


What do you think i should do. Do i need to purchase a midpide designed for the is300??

thx
-mike
 

·
Not Officially Back
Joined
·
12,205 Posts
Err, our engines are the same but I don't think the headers/exhaust piping is the same... I doubt the pipe for an IS will work on your supra. :-?

Maybe ask over on supraforums.com? they might know of a good shop in AUS.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Maybe your right.. but when i look at the xerd race pipe, I see things i need that the boostlogic pipe doesnt have. My headers hook up with 3 bolts, while the BL midpipe has 2. There is also this wire going into my stock midpipe, and the BL pipe doesnt have a space for this, while the XERD pipe does. Tomarow I'll post pics of my header to midpide connection for your opinion.

-mike
 

·
Registered
Joined
·
18,524 Posts
98NAMKIV said:
Maybe your right.. but when i look at the xerd race pipe, I see things i need that the boostlogic pipe doesnt have. My headers hook up with 3 bolts, while the BL midpipe has 2. There is also this wire going into my stock midpipe, and the BL pipe doesnt have a space for this, while the XERD pipe does. Tomarow I'll post pics of my header to midpide connection for your opinion.

-mike
I believe that since you have the VVT-I motor, just like us, we share basically the same, if not exact exhaust piping as you.....

the wire your talking of, on the Y pipe? thats an O2 sensor....

good luck, post on supraforums, people with 98's can help you out moreso then here....
 
1 - 4 of 4 Posts
Top