Lexus IS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
first off i have 2008 is250 6MT.
two nights ago i ran over a shredded tire on the freeway, cracks my front lip...scuffs up my passenger side skirt. so im like big deal i ran over something....

now I got the VSC Check/ engine light all at once driving, as it slowed down and pretty much to a halt. Car did not want to move, I shut the car off now i get a lil bit of power when i hit the gas. its like its limping...like im barely pressing the gas, even though im flooring it. i stop by the local autozone to check the codes and they're all dealing with O2 sensors and MAF sensors. 10 error codes pretty much listed all o2 sensors.

so my question is...do you think it was from the shredded tire i ran over?
or is it something else? any help would be greatly appreciated.
 

·
Premium Member
Joined
·
4,141 Posts
I doubt it would be from hitting a shredded tire unless the CEL and VSC came on right when that happened or right after. It sounds like you're running in "LIMP Mode" right now. I would have that looked at maybe at a Lexus dealership. Are you under warranty?
 

·
Registered
Joined
·
68 Posts
first off i have 2008 is250 6MT.
two nights ago i ran over a shredded tire on the freeway, cracks my front lip...scuffs up my passenger side skirt. so im like big deal i ran over something....

now I got the VSC Check/ engine light all at once driving, as it slowed down and pretty much to a halt. Car did not want to move, I shut the car off now i get a lil bit of power when i hit the gas. its like its limping...like im barely pressing the gas, even though im flooring it. i stop by the local autozone to check the codes and they're all dealing with O2 sensors and MAF sensors. 10 error codes pretty much listed all o2 sensors.

so my question is...do you think it was from the shredded tire i ran over?
or is it something else? any help would be greatly appreciated.
Reset your ECU. You may have damaged some O2 sensor wires or something. As it sounds it is completely caused by you and it is unlikely to be covered by warranty as a defect in workmanship.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
so i did bring it to the dealer. they won't say its covered under warranty, because of the shredded tire i hit. they can see damage from that tire i ran over. one of the O2 sensors on the passenger side u can tell got hit a bit...they're saying the front passenger side rim is bent and all kinds of nonsense. the dealer wont touch anything if theres damage to the car or evidence of an accident. its hard to beleive i ran over a tire and this is what happens...

did a positive discharge to reset everything, but the check engine is still on...so i might just have to get the O2 sensor deal fixed so i can get a running car. and not running in "limp mode"
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top