Lexus IS Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
960 Posts
Discussion Starter · #1 ·
So I received my valve body back from SRT on Friday, installed it yesterday. Drove it a little and then when I tried to put it in reverse or neutral, it would roll forwards as if it were in first gear. Reverse lights come on, Indicator on the dash comes on as if it were in the right gear. But won't go in reverse or neutral.

All parts were installed by SRT on the valve body and all parts were put back together like it came apart.

I was reading that Shift Solenoid Valve No. 1 is on when in Reverse and Neutral(along with other gears)

Could there be something wrong with the solenoid that is causing it not to go into R or N?

the fluid is where it is supposed to be and the valve body was cleaned before being put in.

The pan is already off and letting the ATF drain a little more before pulling the valve body out again. Just seeing if anyone has had this issue or know what may be causing it..
 

·
Registered
Joined
·
1,440 Posts
Not sure, but there is alittle black peice with a spring and a ball. Should be in the front side of the tranny. On the right(pass. side), make sure its back in there. When you take the VB out it should be sitting there on top of your VB. Careful not to lose it, and make sure it goes back in correctly. If not, I don't know what will happen, but this is a start to what "Could" be your problem.
 
  • Like
Reactions: DrpdIS300

·
Registered
Joined
·
960 Posts
Discussion Starter · #3 ·
Not sure, but there is alittle black peice with a spring and a ball. Should be in the front side of the tranny. On the right(pass. side), make sure its back in there. When you take the VB out it should be sitting there on top of your VB. Careful not to lose it, and make sure it goes back in correctly. If not, I don't know what will happen, but this is a start to what "Could" be your problem.
I made sure that was in the right spot. I think I found the problem. seems like one of the pistons/accumulators(SP?) somehow made contact with the top of the port. So I'm ordering a new one and replacing it. IF that's not the issue and there's more to it, we'll find out once the we piston is in....
 

·
Registered
Joined
·
7,824 Posts
My brother and I just did my valve body upgrade and it wasn't the most fun thing in the world to do.

I know that check ball needs to be in there, if you put it in the wrong way it could be causing a problem. I haven't had any problems with mine yet, I've just driven it today after installation it runs rather well.

What did the rods on the accumulators look like, did you have to remove a few springs to fit them or did all springs go back in with it?

On one DIY a few springs are removed but the kit I got I did not have to remove any of the spring. I think it doesn't shift as hard because of it, which is nice because it doesn't slip in any gear and isn't too bad in.
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #5 ·
My brother and I just did my valve body upgrade and it wasn't the most fun thing in the world to do.

I know that check ball needs to be in there, if you put it in the wrong way it could be causing a problem. I haven't had any problems with mine yet, I've just driven it today after installation it runs rather well.

What did the rods on the accumulators look like, did you have to remove a few springs to fit them or did all springs go back in with it?

On one DIY a few springs are removed but the kit I got I did not have to remove any of the spring. I think it doesn't shift as hard because of it, which is nice because it doesn't slip in any gear and isn't too bad in.
I sent the valve body to them and they sent it back. No replacing anything myself.

Like stated before, I believe I found the problem
 

·
Registered
Joined
·
2,753 Posts
does SRT's VB uprade improve all 1-5 shifts?

Kaptain86 which upgrade did you get?
 

·
Registered
Joined
·
7,824 Posts
The one I got is the three pins that go inside of the springs and does not require replacing the springs so that the pins fit into the accumulators.

I think its the toyomoto vb pins.

This is what it looked like,



I'm pretty sure its not possible to upgrade the 1-2 shift or the 2-3. I forget which one it is but its either 1-2 or 2-3 that is basically an electronic overdrive that Lexus used in order to have the transmission be considered a 5 speed transmission.

I've heard of some shop being able to get the manual mode to go into 1st but it doesn't improve much from the way I looked at it.
 
1 - 9 of 9 Posts
Top