Lexus IS Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Hi,

I only have a custom piped cold air intake in my is with no other engine mods. After they put the itnake on, the engine and traction light came on. They reset the car by unplugging the battery, then the trac and engine light went off, for a few days... then it came back on again... I've left it like that for a while but its going to snow in a few weeks and i don't know what to do.

Should I bring it to the dealership? My friend asked a garage for me and they said it might be a problem that will cust like 600 to fix.. I don't know if they're talking shit. What should I do? Whats the problem?
 

·
Registered
Joined
·
548 Posts
WRONG FORUM
hey man im not sure why your trac light came on. could be a wiring problem its possible someone did something they shouldnt have somewhere else, although ive heard similar problems with installation of headers with the Trac coming on newer model cars such as 2003+, ull need a Apex-S-AFC and tuned to fix the cel light..
 

·
Moderator
Joined
·
8,852 Posts
That error code - Flashing Trac and CEL is the result of incorrect MAF readings.
First, make sure your MAF is properly installed.
Second, Purchase AFC (Air/Fule Controller) and have your car tuned.

Better yet, scrab the whole custom intake idea and call SRT.
Get their whole intake setup. It will cost you less overall than to have the car fixed.

Going to the dealership will only cost you $$$ because it is your mod that is the cause of the problem.
 

·
Not Officially Back
Joined
·
12,292 Posts
Your intake is allowing more air into the engine, so the AF mixture is off. You can unplug the battery to reset the error code, but it will come back after you drive 500 miles. Only way to fix it is to get an AFC to correct the air/fuel mixture, or go back to the stock intake.

Your cold air intake is just for show without an AFC... you can actually lose horsepower because your AF mixture is screwy.
 

·
Registered
Joined
·
30,490 Posts
oneeyejack said:
your problem is there is no CAI for the IS that work!!!! :wink:
He may be a masshole, but he's right...

how much did you spend onthis "custom intake" and what did the fabricators have to say about your problems?
 

·
Moderator
Joined
·
13,903 Posts
s0yb0mb said:
oneeyejack said:
your problem is there is no CAI for the IS that work!!!! :wink:
He may be a masshole, but he's right...

how much did you spend onthis "custom intake" and what did the fabricators have to say about your problems?
nope...not a masshole and i'll never be one.

unfortunately i just work in this horrible state.
 

·
Registered
Joined
·
11,917 Posts
the code you are seeing is "don't use pvc anywhere on a lexus, instead of being cheap, buy an intake system if you own a lexus. if you don't have the money to afford one, sell the lexus and get a less expensive car, and if your parents bought it for you, don't modify it"

thats more of a summarization of the check engine light code, i can't remember the entire thing off of the top of my head

if you look in the manual, its code P3040

-gte




dj-jay said:
Hi,

I only have a custom piped cold air intake in my is with no other engine mods. After they put the itnake on, the engine and traction light came on. They reset the car by unplugging the battery, then the trac and engine light went off, for a few days... then it came back on again... I've left it like that for a while but its going to snow in a few weeks and i don't know what to do.

Should I bring it to the dealership? My friend asked a garage for me and they said it might be a problem that will cust like 600 to fix.. I don't know if they're talking sh*t. What should I do? Whats the problem?
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top