Lexus IS Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So, I crossed my polarity in a 2002 is300. Battery was put on backwards and then turned over the engine. I went ahead and changed all the fuses and relays that were blown, the computer, but still have no spark. Any ideas on how to get my ride to fire back up? Could it be cool packs? If it is, is there a way to ohm them out to test before I buy all 3 and still possibly have a problem?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Yes the battery is in working order. Not 100% on fuel, but still not starting even when either is used. The ecu was through flagstaff and was programmed to the car already
 

·
Moderator
Joined
·
4,161 Posts
Okay, so it ran fine till the crossed terminals.Right? Is the security light going off with the key?
 

·
Registered
Joined
·
2 Posts
Once the key is near it should not be blinking.
I know “a friend” that did the same thing on a ‘08 350. With all that you have done, it may need to go to the dealer. His did. It does a freakin’ number on of a bunch of stuff that you wouldn’t even think are connected. Damn Lexus for positioning the + side cable on the wrong side.
 

·
Registered
2005 Lexus IS300
Joined
·
67 Posts
ive seen this a few times the last week or so. how do you guys so easily cross polarity. I am barely able to get my terminal ends to reach the correct terminals let alone the opposing one
 

·
Registered
Joined
·
1,224 Posts
I have wondered the same and can only imagine something similar to Tobias, though in my experience even then the cables were never long enough even then.... not that i have tried... honest :p :LOL:
 
1 - 14 of 14 Posts
Top