Lexus IS Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
837 Posts
Discussion Starter · #1 ·
just like the title says...

HOW do you turn off the Maint. Req'd light?
i have my car check up and oil changes with a trusty family mechanic. and i left without him turning off the light lol.. so i wanted to do it myself.. i read the manual and i didnt find anything on how to turn it off...

So... if anyone can help me out please..
 

·
Registered
Joined
·
2,092 Posts
this is straight from a 2004 owner's manual (p54)

1. Turn the ignition key to the "OFF" position with the odometer reading shown.

2. Turn the ignition key to the "ON" position while holding down the "ODO/TRIP" button.

Hold down the button for at least 5 seconds. The odometer indicates "000000" and the light goes off.

If the system fails to reset, the system will revert to the state before resetting operation. In this case, return to step 1 and try again.

:)
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #3 ·
lmao thanks.. yea i guess i didnt read the manual tooo closely.. i shall try on my lunch break.. thank you very much :D
 

·
Premium Member
Joined
·
6,292 Posts
01s do not have Maintenance Required Light. :) I think Lexus started putting that light in 02.
 

·
Registered
Joined
·
558 Posts
black86 said:
this is straight from a 2004 owner's manual (p54)

1. Turn the ignition key to the "OFF" position with the odometer reading shown.

2. Turn the ignition key to the "ON" position while holding down the "ODO/TRIP" button.

Hold down the button for at least 5 seconds. The odometer indicates "000000" and the light goes off.

If the system fails to reset, the system will revert to the state before resetting operation. In this case, return to step 1 and try again.

:)



so thats how to turn it off i had mine done on 11000 mileage and when it hit 13000 mileage the maintance light came on and drove it like that ever since, to busy to go to the dealer to turn it off LOL
 

·
Registered
Joined
·
837 Posts
Discussion Starter · #9 ·
soooo i did that and when i have it to 'off' the odo doesnt show and yes i have it out of 'lock' i held the shit down for 10 seconds lol
maybe i should keep tryin but yeh.. its not working for me :(
 

·
Registered
Joined
·
2,092 Posts
i think its a bit unclear, but turn the key to on first, without starting and make sure it isnt on trip A or trip B but on ODO then go back to off, hold the reset button and turn the car back to ON and it should go "000000" and the light should turn off. let me know if that works. im due for another oil change within 1K miles, so i did this a while back... but i think thats the process. :p good luck
 

·
Registered
Joined
·
5,028 Posts
FenKa-Lex said:
great thread IMO :bigSmile: if i knew how to give rep i would.
Just click on this icon
under the person's user name
 
  • Like
Reactions: FenKa-Lex

·
Registered
Joined
·
229 Posts
This thread has been helpful thank and + rep.
 
1 - 17 of 17 Posts
Top