Lexus IS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter · #1 ·
How did you run the wires for the speakers (mids). I am trying to decide which route I want to go.... Did you mount the amp in the trunk and run wires from it to each individual speaker (or Xover), or did you run the wires to the dash and connect to the factory wiring? I have AM rears waiting to go in, buying fronts and amp soon and I want to do it all at the same time. I have an AM deck and I don't need any advise about that or power/ground/remote/rca wiring I already did that a while back when I put the amp and sub in.
Thanks
 

·
Premium Member
Joined
·
11,398 Posts
I mounted my amp in the trunk. It's pretty much the only place for it because there is no room under the front seats. I ran individual aftermarket wires from the amp to the crossovers and then from the crossovers to the speakers. I wouldn't mess with the factory wiring since it's pansy anyways.
 

·
Registered
Joined
·
154 Posts
Discussion Starter · #3 ·
Thanks Italyn - That's what I was leaning towards doing, just wanted a little more input. Sounds easier to do it the other way, but more secure and better all around to spend the extra time to do it a better gauge wire all the way to each speaker.
 

·
Premium Member
Joined
·
11,398 Posts
Yeah, better to do it right. I would also suggest coating the baffles in something to seal them from absorbing water. The will eventually get water in them and swell. Do it right the first time, it's worth it.
 
1 - 5 of 5 Posts
Top