Lexus IS Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
7,294 Posts
Discussion Starter · #1 ·
So I have had the Area 51 sway bars for about 2 years. How often are you suppose to grease or lube the bushings? Im getting this horrendous squeeling everytime i go over a bump until the engine bay gets hot then it dies down but comes back IT sounds like its coming from right behind the bumper if i rock the car in park.

It just happened when the weather got cold...
Im guessin sway bar lube is needed? :)

Anyone else have this as the weather just got brutal in the NorthEast?
 

·
Registered
Joined
·
42 Posts
use the lithium grease with teflon(sp?) in it.

that's what i used on my sway bar and i never had to re-grease it again.

good luck!
 

·
Registered
Joined
·
769 Posts
i just took my front bushings off to clean and relube. I had similar noises when driving over a bumps. Second time i've had to do it and i've had my sways on since A51 had them out.

The bushings were covered in all kinds of dirt and salt. But after a little cleaning, they're like new.
 

·
Registered
Joined
·
7,294 Posts
Discussion Starter · #6 ·
Oh Shat... well it looks like I got myself a little project when i get home in the dark tonight and its windy and 28* outside :lol:

This shat couldnt just have happened a few weeks ago when in was like 60* out :roll:

Thanks for the tips....
 

·
Registered
Joined
·
7,294 Posts
Discussion Starter · #7 ·
Problem Solved!

I cleaned and regreased the Sway Bar bushings with some good ol non-water soluble axle grease (marine grease) I lined the entire inner bushing with a 1/16th coating and slipped it back onto the bar. tightened the four 12mm bracket nuts back on until they were tight and some of the grease was protruding from the bushing sides. Bolted back up the underpanel. and went for a test drive...........

SILENCE! no knocks no creaks. Im a happy camper once again.

TOTAL TIME: 60min in below freezing temps! :lol:
(looks like i work efficiently in colder weather)
 

·
Threadlocker
Joined
·
7,912 Posts
congrats! knocks usually come from loose bracket bolts, while squeaking comes from dirty bushings... glad you solved your problem... in the cold ass temps even.
 

·
Registered
Joined
·
1,775 Posts
BigDaddyRich said:
Problem Solved!

I cleaned and regreased the Sway Bar bushings with some good ol non-water soluble axle grease (marine grease) I lined the entire inner bushing with a 1/16th coating and slipped it back onto the bar. tightened the four 12mm bracket nuts back on until they were tight and some of the grease was protruding from the bushing sides. Bolted back up the underpanel. and went for a test drive...........

SILENCE! no knocks no creaks. Im a happy camper once again.

TOTAL TIME: 60min in below freezing temps! :lol:
(looks like i work efficiently in colder weather)

You told me to use marine grease months ago. What the hell have YOU been [email protected]!
 

·
Registered
Joined
·
7,294 Posts
Discussion Starter · #11 ·
stick said:
BigDaddyRich said:
Problem Solved!

I cleaned and regreased the Sway Bar bushings with some good ol non-water soluble axle grease (marine grease) I lined the entire inner bushing with a 1/16th coating and slipped it back onto the bar. tightened the four 12mm bracket nuts back on until they were tight and some of the grease was protruding from the bushing sides. Bolted back up the underpanel. and went for a test drive...........

SILENCE! no knocks no creaks. Im a happy camper once again.

TOTAL TIME: 60min in below freezing temps! :lol:
(looks like i work efficiently in colder weather)

You told me to use marine grease months ago. What the hell have YOU been [email protected]!
:lol:
I used the little mini tube-o-grease that Area51 packed in/ shipped with my sways. it obviously wasnt enough but it worked for 2yrs trouble free. But I finally took my own advice!! :lol:
 
1 - 11 of 11 Posts
Top