Lexus IS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
Hi guys

I have a custom CAI, and its been tripping the trac light to flash and the engine light comes on... I bought the SAFC to fix the problem as recommmended by others on the forum, is there anything specific I have to set to fix the problem? Because its still coming on and I'm just unplugging the battery everytime it happens right now. My SAFC isn't dyno tuned yet, but I feel a significant increase in power across all rpm ranges, but everytime I unplug the battery, the settings (without altering MAF) keep getting reset. I'm pretty sure the CAI has no air leaks, what to do?
 

·
Registered
Joined
·
4,416 Posts
dj-jay said:
Hi guys

I have a custom CAI, and its been tripping the trac light to flash and the engine light comes on... I bought the SAFC to fix the problem as recommmended by others on the forum, is there anything specific I have to set to fix the problem? Because its still coming on and I'm just unplugging the battery everytime it happens right now. My SAFC isn't dyno tuned yet, but I feel a significant increase in power across all rpm ranges, but everytime I unplug the battery, the settings (without altering MAF) keep getting reset. I'm pretty sure the CAI has no air leaks, what to do?
How did you tune the AFC? What A/F ratio did you tune things to?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top