Lexus IS Forum banner

141 - 160 of 175 Posts

·
Registered
Joined
·
2,639 Posts
Thanks for the responses guys, I have an Aristo 2jzgte vvti and its using the stock wasted spark method. Can the LQ9 kit be a conversion kit also from wasted spark to direct coil on plug? Curious, would you know if this would require a retune on a stand alone? (ProEFI)
 

·
Registered
Joined
·
1,201 Posts
Yeah they can be used as either or, and probably a retune because if your running your stock ignition module now you wont be with the LQ9s, and youll have to set it up on your EMS
 

·
Registered
Joined
·
272 Posts
Discussion Starter #144
Can the LQ9 kit be a conversion kit also from wasted spark to direct coil on plug? Curious, would you know if this would require a retune on a stand alone? (ProEFI)
These coils can be wired to run waste spark - and work well in that configuration firing in pairs - but doesn't the PROEFI support coil-per plug? They would need to have some ECU settings changed, specifically the firing mode if you go to coil-per-plug - and dwell settings. There also would be some wiring changes required to hook up the extra ignition outputs to the coils if changing firing mode. After that, it probably would be a good idea to recheck timing and monitor AFRs to feel good about it.
 

·
Guru of Supercharged ISs
Joined
·
8,744 Posts
hey Rick great to see your baby is coming back better than ever !...

Sadly,... i am still dealing with my misfire problem... been workign a TON and on the road alot so had no time lately for anything but work....

i am at my diy hackjob wits end trying to figure this out on my own here so here is my question....I have accepted that I just need to take it to a shop... but with all the "stuff" going on with my motor most shops look at the car & say "WTF? I don't think so...."

So,... i need a GOOD shop willing to dig around a modded car ... in SFV/SGV - LA....

At this point we know it is misfiring consistently,..... once in a while it will be bad enough that it feels like i dropped a cylinder but most of the time it is just bad enough to idle rough and throw the consistent random misfire codes P0300 thru p0306 i think...( one for each cylinder plus the Random code as well...7 total) but strangely enough....it is very driveable and smooths out dramatically above 2500 rpm... Per BLacksportD's review of the logs from the EMU the Ign Advance is jumping all over the place up to 60+ deg of advance & then back downto where it should be,... the trace looked like a richter scale plotter after the big quake out here in '94 ....

what I need to know is with my setup what will a shop need to do / use to determine what is sending a bad signal to the ECU that is causing the ECU to bounce my ignition advance all over the place ... i am trying to ask potential shops specific questions that will tell me they have the tool/ability to do the job Vs taking the car there because they say "Sure bring it in" we will take a look at it... Sean mentioned needing an ocilloscope... but i have no clue how that would be used to figure this out And if i need to make sure the shop i go to has one ....

I am willing to spend the money to get this bitch fixed but now i need to know where to take it,... the average indep. lexus service shop is not the place.... and the dealer is a non option... i'm not willing to spend THAT much... :)

thanks doods


& dayumn Rick as soon as i get thie aggravating problem sorted we can tune it & THEN go to hte next level ignition... i am sitting here with a box of beautiful parts that are jsut collecting dust & its pissin me OFF...
 

·
Registered
Joined
·
272 Posts
Discussion Starter #146
Delayed Gratification City

Well, After not receiving any wrist pins for months, I rescued my stuff from the machine shop and shipped the whole mess (Rods and pistons ) to PAECO, the ones that originally built the crank and spec'ed the Venolia pistons - with instructions to check and measure everything. They found that four of the pistons' pin bores were distorted. Not surprising given that the pins were bent - Rods' small ends look good thankfully. New pistons complete with pins are on order, with an eta of 6 weeks. Can anything else go wrong, take more time, and cost more money?

I'm not quitting but I'm damn tired of this.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #150
Why is it so hard to give companies your money these days?
That is the question of the day.

According to my calendar, I'm 2-1/2 weeks away from being ready (pistons' eta) to assemble my engine. Pretty sure this guy can deliver as promised.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #152
Short block is built (Machine shop made some fine tweeks to clearances), lash is set for the 272s.

The rest of the engine will go together this weekend, probably will install in the car early next week.



I almost can't believe it's getting done!
 

·
Registered
Joined
·
1,618 Posts
Love the progress bro, hopefully ill be the next in line doing a serious budget stroker setup. I plan to work with OEM knife edged and worked crank in GE block. I'm hoping to have a nice 1000 horsepower car

I wish I was closer, I'd love to see the progress in person. I'm in Tampa
 

·
Technical Poseur
Joined
·
23,313 Posts
I'm really excited for you Rick. I hope it all goes well. Do me a favor and rotate the engine by hand like...9-10 revolutions once you put the timing belt on. I just dont want to read a thread about how you forgot to check that and bent all the valves. I'm sure you will remember but this is a reminder from someone who wants to see this awesome critter run.
 

·
Registered
Joined
·
2,639 Posts
Hey Rick, any updates on the car? Just letting you know a few days in advance... I'll be ordering that LS9 coil kit =) Been trying to save for it lol....
 

·
Registered
Joined
·
272 Posts
Discussion Starter #157
Just brought the car home from the shop last night - under its own power - will be washing off the dust today, charging AC and beginning the tune. I decided to clean up a bunch more Previous Owner stuff and waited to get it back on the ground until that was done.

All the earlier pictures I had posted are gone with my brother's server crash - I may make another build thread but for sure will post more pics.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #159
Well, looks like the engine will probably come back out. Lots of oil smoke, and I don't believe it's the turbo. I had problems with the crank angle sensor getting it started and was worried about new rings + raw gas.I was hoping that a ring break-in routine would help but all I'm doing is spraying for mosquitoes.

I'll swap on another turbo and make more checks just to make sure before engine pulling - there's only three places oil can come from, and two of them require engine removal (I have head studs and don't think the head will come off on the car).

Can't catch a break - Should be used to it by now.
 

·
Registered
Joined
·
297 Posts
Rick are you running arp head studs. If you are the head will come off in the car. just pull the cams and loosen the 13mm 12point nut then the studs should have an allen key spot on the top of them to back them out. they should only be finger tight or just a hair tighter once the nuts are loose
 
141 - 160 of 175 Posts
Top