Lexus IS Forum banner

61 - 80 of 175 Posts

·
Registered
Joined
·
5,941 Posts
Oh, so the original build was not by PFS? This thing has had what, five - six known owners in its 44K miles,about 8K of which have been mine. Like I have said, there was evidence of many different hands on it...some not too skillful.
The original turbo setup was a SRT kit. I don't know if the engine was built though but afterwards the car was completely redone at PFS and made 600+ rwhp with cams. I remember after Aldo (Ltuned&Boosted) had the car, he traded it for a white MKIV, then it was sold. It might have went to another owner then to Vinny Ganz then to you. I almost remember some girl keyed the car and wrote "F*ck You" on it. The car looks amazing with your work no matter how much history it had.
 

·
Registered
Joined
·
503 Posts
I was at Ricks shop last week, this car has come a long way since my brother owned it. I't really looking nice.
 

·
Registered
Joined
·
503 Posts
My brother bought this IS from someone other than Aldo, not sure what his name was. Vinny was really stressing with that car, he thought it was a great deal but then out of nowhere it would just stop running, he had some shop up in Lakeland try to fix it but they just made it worse... I PM's ZGAD one day with as I seen him at the track with a stanalone 2JZGTE 240Z, I was looking for someone to install a Haltech in my GS300 and it just so happened Rick was the guy ZGAD reccomended, thank god for that lol... I was planning on dropping my car off but my brother asked if he could go first, before Rick could give Vinny a bill he bought the car lol.. My brother was very happy as he wanted out of the payment and wanted to go back to school for his masters. My car went in next for the standalone, but soon I wound up asking Rick to install a V160 in my GS300, in the endmy car turned out great, 630 RWHP at 24psi.. it really hauls, such a fun car to surprise people with.

Rick I'll call you next week, need some welding / IC smoothing as i'm going to chrome the pipes.
 

·
Registered
Joined
·
6,754 Posts
The original turbo setup was a SRT kit. I don't know if the engine was built though but afterwards the car was completely redone at PFS and made 600+ rwhp with cams. I remember after Aldo (Ltuned&Boosted) had the car, he traded it for a white MKIV, then it was sold. It might have went to another owner then to Vinny Ganz then to you. I almost remember some girl keyed the car and wrote "F*ck You" on it. The car looks amazing with your work no matter how much history it had.
i remember this too. the car was originally built by SRT then there was some drama and Aldo took the car over to PFS to finish. at the time SRT and PFS had a rivalry and this car was used in a "shoot out" meet. car was supposed to make 600hp but at the meet made much less. of course PFS claimed SRT did something to the dyno.

other owners im not too sure about. i thought i heard somewhere that the car was out in Texas or something. if you run a carfax you should be able to see how many owners and the states the car was registered

wheres TSprano? we could use him now. he used to keep tabs on everybody's car and was "in" on all gossip

if youre interested i dug up some pics from the 2003 PFS BBQ meet
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01357.jpg
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01356.jpg
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01355.jpg
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01354.jpg
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01352.jpg
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01353.jpg
http://i251.photobucket.com/albums/gg301/baadhabit_2008/2010-08 OLD PICS 2003-06/DSC01351.jpg
 

·
Blue Devil
Joined
·
4,671 Posts
awesome man! hope we get to see it in person at a future South FL mega meet.

2.5-3 hrs away is a hell of a lot better than the trip i took up to SRT in 2008. if i get around the gathering all the parts for the install i eventually want to do, now i know who i'll need to call! ;)
 

·
Registered
Joined
·
272 Posts
Discussion Starter #67
if youre interested i dug up some pics from the 2003 PFS BBQ meet
Thanks for those Ray - I notice some bastard took off the nice brakes it used to have...
 

·
Registered
Joined
·
272 Posts
Discussion Starter #68
awesome man! hope we get to see it in person at a future South FL mega meet.

2.5-3 hrs away is a hell of a lot better than the trip i took up to SRT in 2008. if i get around the gathering all the parts for the install i eventually want to do, now i know who i'll need to call! ;)
I will be at the next Mega Meet...and I will be needing more business after being laid-off from the "real" job late this/early next year.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #69
Tuning is being held up again -this time by the need to track down a mysterious ignition miss - I suspect wrong plugs for my coils.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #70
I'm having problems with what feels like ignition misses. I suspect it may be a problem with spark plug compatibility with my coil setup. I will try the NGK TR6 plugs as used by the LSx turbo guys.

I have played a bit with dwell settings, going from 2.4 to 5Msec, with little effect.

While I have the coils off I will also closely examine the springs inside the coils' HV towers to make sure they are making good contact on both sides.

I really want to make these coils work - but do have a set of the GTE coils and Haltech igniters if it proves to be too big a pain. I actually made the coils' harness with a connector to facilitate this. I figure that, according to Murphy, if the swap is made easy to do then I won't need to do it.

I'll report progress or lack thereoff.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #72
looking at your other thread, what was the miss-problem attributed to?
EMS timing settings. Way retarded with no advance. I won't elaborate but it was a stupid mistake.

I can say that the LS2 truck coils-on-plugs are a success. After getting timing/advance working correctly, I increased the dwell from the 2.4 ms that the Supra coils were running up to 5.0 ms and the low load/idle got smoother at every increase. I increased the plug gap to .034". Just getting into tuning positive manifold pressures and ignition looks crisp with no knock being indicated on my J&S.

I'm not quite done tweeking - I have a stumble at moderate boost(maybe too much dwell?) that I haven't isolated yet, but am confident that it will be solved.
 

·
Registered
Joined
·
272 Posts
Discussion Starter #73
OK, tuning is back on track. For some strange reason, the new Haltech PS2000 base tune I made using VE tuning method didn't work too well, even with duplicating most of the setup from the nicely perfected calibration that adamgamz is running. I just took Adam's tune, trimmed fuel +15% for the added cubes of my stroker, tweeked trigger settings for my crank/cam sensor setup, and it's pretty good. I have a few issues to work but they do seem to be fixable.

I drove it to work tonight (I work 3rd Shift at KSC) for the first time since getting it going with the new motor - Ideal time for street tuning.

Feels good to have my IS back!
 

·
Registered
Joined
·
272 Posts
Discussion Starter #74 (Edited)
I guess it's time for a mod list.

Engine:
Lexus GS300 GE block bored 1mm 87mm bore
PAECO stroker crank, 94mm stroke
Venolia forged pistons tops/sides coated, floating pins w/teflon buttons - built to 8.2:1 compression ratio
Deves rings
BC Pro connecting rods
ARP head studs, rod bolts, main studs
Cometic 51mm MLS Head gasket
Lexus IS300 GE head lightly ported (port matched, ports/chambers cleaned up/smoothed)
Ferrea severe duty valves 1mm oversize
BC Valve springs w/TI retainers
HKS 264 GTE cams
Titan cam gears
VVTI removed, GTE intake cam reworked to fit
Head machined to fit a center cam sensor, rear cam sensor hole blocked off
PCV upgraded with KRANK check valves on the breathers
to do: two catch cans in battery area after battery is relocated to the rear

There have been some excellent writeups by other members on building a 2J - I won't try to improve on them here.

EMS:
Haltech PS2000,running sequential injection and direct fire ignition
GM LS2 "truck" coils modified to fit directly on plugs
J&S Safeguard Interceptor knock controller
Innovate LC1 with AFR display

Fuel:
Delphi 1000cc injectors
Aeromotive FPR
SRT Dual Walbro pump Hanger
Dual Walbro 255 pumps -Second pump is staged by the Haltech

Turbo:
Comp Turbo CT43-72, Triple ball bearing center, 72 mm compressor, .84A/R hot side
HKS EVC-5 boost controller
Canton Turbo oiler
HKS Super Megafow air filter

Transmission/Drivetrain:
V160
B&M shifter
Tilton 7.5" triple carbon clutch, 12-pound flywheel
Custom 1-piece 3" steel driveshaft with 1350 u-joints
MkIV supra rear 3:13 ratio

Suspension/Brakes/Wheels
Tien coilovers with EFDC
HRE 640 wheels, 19" diam, 10" rear, 9" front (I'll post offsets when I find them)
Toyo T1R tires, 265/30 rear, 235/35 front
Fenders pulled/rolled
to be installed- Supra TT discs/calipers

Gauges
Greddy electronic boost, fuel pressure, and EGT
TRD center gauge pod
 

·
Registered
Joined
·
272 Posts
Discussion Starter #75
Took the car on its longest drive yet - 40 mile round trip to Orlando for a Wed night Lexus/Supra meet. Driveability tuning is still going well, car drives nice except: Found that on cold starts my J&S picks up on forged piston slap and clutch rattle, then retards spark to the point where the engine stalls easily until fully warmed up. I'll have to think about a way to deal with this - otherwise just live with it.

I've tuned boosted operation to 15psi and feels good, will keep it there until some more break-in happens.
 

·
Registered
Joined
·
744 Posts
(took Comp Turbo 2 weeks and 2 shipments to provide a restrictor -.014":suspiciou - and filter)
I waited a bit over a month to receive a oil return flange from them...

This car is going to be a beast, you must post some video's when it's all done.
 

·
Registered
Joined
·
5,941 Posts
Took the car on its longest drive yet - 40 mile round trip to Orlando for a Wed night Lexus/Supra meet. Driveability tuning is still going well, car drives nice except: Found that on cold starts my J&S picks up on forged piston slap and clutch rattle, then retards spark to the point where the engine stalls easily until fully warmed up. I'll have to think about a way to deal with this - otherwise just live with it.

I've tuned boosted operation to 15psi and feels good, will keep it there until some more break-in happens.
Couldn't you turn on an output such as a ground to turn on the J&S when the coolant reaches a certain temperature? Looking at the J&S wiring and instructions, the knock retard shouldn't activate until you're at 1750 RPM and below 5" of vacuum so drive at a lower RPM and load until the motor warms up. Though that's not a great solution.
 
61 - 80 of 175 Posts
Top