Lexus IS Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 · (Edited)
ok so i just figured it out - was having the same problem as many on here. maybe i can describe it to other newbies. my is300 has the sun roof. there are 3 main components:

component 1. "guts" of moon roof wiring and buttons which includes the tilt, open/close sunroof and front map dome light on/off button. This core piece is recessed in ceiling and screwed into the roof. It also houses the actual light bulb.

component 2. Plastic (grey in my case) cap or cover (between pops off from component "1".

component 3. Clear plastic lense. DO NOT TRY TO POP OFF CLEAR LENSE - IT IS PERMANANTLY BOLTED TO THE THE PLASTIC COVER (ITEM 2).

Do not pull TOO hard on the entire thing or you may damage the "1". But you do have to put some effort into snapping "2" off from "1". There are 2 little claws on the side near the rear that need to get unclipped.

Here is a final picture after I finally got it off:

<br>

<br>

the bulb read: "LIFE 12V10W-C" on the metal part.
hope this saves someone the frustation i was facing!
 

·
Registered
Joined
·
56 Posts
where are these two plastic claws? Everytime I try to pull it off it looks like I'm trying to take out the entire component 1 and component 2. Should I be pulling from the front, or the back? Did you use a flathead screwdriver? Any help here will be appreciated. Thanks.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
the two claws are on the side facing the back, you can kinda see the features on "1" on that pic. try pushing on the center of one of the buttons (or a couple buttons) while you pull down on the plastic cover. this should separate the two. but dont break your buttons.
 

·
Registered
Joined
·
4,258 Posts
great post, thanks for sharing! and welcome! +rep
 

·
Registered
Joined
·
35 Posts
I actually replaced the bulb in mine. but it seems like there is a loose wire, sometimes it turns on and sometimes it doesnt. I took out 2 screws and the whole panel. but couldnt get the socket off.

anyone know how to take apart the socket in the back?
 

·
Registered
Joined
·
459 Posts
Pics are not showing up. Can you reload the pics. I'm trying to replace the map light bulb but am afraid i'll rip the whole thing down, or bust the screw that holds it up. Thanks
 

·
Registered
Joined
·
3 Posts
replacing sunroof / moonroof map light

moonlight said:
ok so i just figured it out - was having the same problem as many on here. maybe i can describe it to other newbies. my is300 has the sun roof. there are 3 main components:

component 1. "guts" of moon roof wiring and buttons which includes the tilt, open/close sunroof and front map dome light on/off button. This core piece is recessed in ceiling and screwed into the roof. It also houses the actual light bulb.

component 2. Plastic (grey in my case) cap or cover (between pops off from component "1".

component 3. Clear plastic lense. DO NOT TRY TO POP OFF CLEAR LENSE - IT IS PERMANANTLY BOLTED TO THE THE PLASTIC COVER (ITEM 2).

Do not pull TOO hard on the entire thing or you may damage the "1". But you do have to put some effort into snapping "2" off from "1". There are 2 little claws on the side near the rear that need to get unclipped.

Here is a final picture after I finally got it off:




the bulb read: "LIFE 12V10W-C" on the metal part.
hope this saves someone the frustation i was facing!
I realize this is a year old post. Can you tell me how to pul back up the pictures so I can visualize better the correct way to do this procedure ? I have tried all different ways from pulling the whole section 1 out of the overhead, prying with a putty knife along all cracks in section 2 with no success. All I get is an occasional crack or pop, at which time I quit and do more searching
 

·
Registered
Joined
·
92 Posts
I just did this about a week ago. What you have to keep in mind is the cover you are removing is pliable where the plastic house (1) is a hard plastic. This should help you "peel" off the outer cover.
 

·
Registered
Joined
·
167 Posts
Just popped open my 02 IS300 interior bulb housting yesterday, WOW WHAT A PAIN IN THE ASS! I used a small flat head screwdriver to CAREFULLY pry the housing down, then pulled forward to help release the two tabs. It wasn't easy.

I found a few "working" bulbs at the local auto parts store, but I'm now convinced they are all trash. For those of you replacing your IS300 dome light, make sure you go to Toyota for the OEM bulb! The bulbs at AutoZone, Advanced Auto, etc are generic and are not made for a *primary interior light*. The generic bulbs are not made to be super bright.

Just ordered one today from Toyota for $5. Going LED was tempting, maybe next time.
 

·
Registered
Joined
·
176 Posts
I think I may have blown a fuse or something during replacement. After I changed the bulb it no longer works, neither does the door ajar light, and my key remote doesn't work either. Perhaps because I used bare hands to do it? I'll have to check it tomorrow or something. Does anyone have a more experienced opinion? My best guess is the fuse.
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top