Lexus IS Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6,193 Posts
Discussion Starter · #1 · (Edited)
I hope somebody can help me out. My power mirrors and radio just dies on me. I checked the minis with a continuity tester and looked at the larger fuses. Everything seems to be OK. I even tried resetting the ECU. I looked at the power wired for the mirror tilt, but I didn't see any damaged wiring. I still have to remove the HU, and look at the power wires. AFAIK, everything else seems to be working.

This happened while I was setting my Token mirror tilt. The mirror stopped moving, and the radio (AVIC Z1) shut off. Maybe I possibly missed a fuse, but I checked the Radio 1&2 fuses at least 3x. Has this happened to anyone else? I'd appreciate all the help I can get. Thanks!

Edit: no power to climate control either.
 

·
Registered
Joined
·
1,910 Posts
sucks to hear Rey, but u wired everything urself so it should be easy for u to diagnose...
 

·
Registered
Joined
·
6,193 Posts
Discussion Starter · #3 · (Edited)
I was in a hurry to get it fixed because I had to pick up my son, and I got a little sloppy while checking it out. I swear I checked the Radio fuse in the driver's kick panel multiple times, and got the green light from the fuse tester. When I pulled it, and looked at it, I could see that the fuse was just barely gone. I took one of my spares, popped it in, and now everything is back to normal.

Recap: Radio fuse (10A) in driver's kick panel = no power to Radio, P/Mirrors, clock, temperature display, and ignition key light.
 

·
Registered
Joined
·
1,324 Posts
nice.
sometimes fuses pop and you will have good continuity and a green light and 12 volts on both sides. but when it is inspected its just barely cracked and touching just wont allow that much current to turn on the parts..
 

·
Registered
Joined
·
277 Posts
Had to Raise this from the dead

Bless you sir! You saved me hours upon hours here.

I had my Oil Press, Wideband, Boost gauge, not to mention some of my audio tapped from this exact location.

I had a fuse block extension, with a 10 amp fuse that was good in place. After searching around tonight for "Power Mirrors, temp display, clock, Radio not working" i found this. I pulled the fuse block extension and just dropped back in the same 10 amp fuse and everything was working.

I will have to pull power to my gauges from another location for sure. In my case the fuse was not bad or sorta bad I was just asking to much from the Radio 2 location on the driver side.
 

·
Registered
Joined
·
6,193 Posts
Discussion Starter · #7 ·
djspock3030, I'm glad you figured it out.

valhallab, The TS mirror tilt is a really nice item. It basically works as an up/down timer, so you can adjust it to your needs. I've had it installed for a while with no real issues. I think I've blown the included 2A fuse once or twice in a couple years, but that's it.
 

·
Registered
Joined
·
6,193 Posts
Discussion Starter · #9 ·
Correct.
 
  • Like
Reactions: valhallab

·
Registered
Joined
·
510 Posts
Did you get the single unit or the deluxe (double-for both mirrors)? If you got both, how hard is it to set the two timers to the same time? Did you notice the min or max time? I might be able to pin em to get them equal.
 

·
Registered
Joined
·
6,193 Posts
Discussion Starter · #11 ·
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top