Lexus IS Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6,086 Posts
Discussion Starter #1
Ok guys..I bought a product from an online company..it didn't work..so I sent it back.

That was over 2 months ago..and I have not received an e-mail from them..or even a call..whenever I do call them...they won't give me a refund because it was "used" and now their phone system is down and to e-mail them..which I have, and still no response.

Anyone got any suggestions?
 

·
Registered
Joined
·
4,510 Posts
ImpulseXvX said:
R808IS300 said:
What payment method did you use???
Credit Card...no refund has been posted and no other charges have been made.
did you send it UPS or somethnig? the company can just say "we never got it" ...which totally sucks but credit card companies will be on your side. Tell them the situation and hopefully you can get your money back. goodluck.
 

·
Registered
Joined
·
6,086 Posts
Discussion Starter #8
UpTownIS300er said:
did you send it UPS or somethnig? the company can just say "we never got it" ...which totally sucks but credit card companies will be on your side. Tell them the situation and hopefully you can get your money back. goodluck.
Ok..thanx man..yea...I've got the shipping/tracking # from when I sent it back...
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
5 Participants
ImpulseXvX
Lexus IS Forum
Community dedicated to Lexus IS Enthusiasts. Come in and enjoy our articles, galleries and information on aftermarket parts for the IS300, IS250, IS350.
Full Forum Listing
Top