Lexus IS Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,445 Posts
Discussion Starter #1
so yea i heard alotta buzzin from my engine bay.

so i checked everything else and then narrowed it down to the heatshield.

i loosened the bolts and put them back on tightly but still buzzy.

then i took it off only to find that there are cracks where the screw holes were leading to the edge.

sure i've had it for more than a year or so ...but i expect to pay for smtehing that lasts.

i have the first run of heatshields without the sides

i'll post pics later
 

·
Premium Member
Joined
·
16,944 Posts
Email the company that makes them, but please take pic's, i have only head of the one with end caps having issues..... Sure it would be news to them on urs.

Maybe not, who knows, Ask Mike

David
 

·
Registered
Joined
·
4,027 Posts
your not the first person with problems with these heat shields.
edgy and myself have had problems before. unfortunately, mike at PLP is unwilling to lend a hand once hes sold the merchandise.. more or less, we are on our own after purchase..

id hate to think its the same deal with his s/c's, especially if someone had a problem with theirs..
 

·
Runs on Rice
Joined
·
2,900 Posts
dpatterson069 said:
your not the first person with problems with these heat shields.
edgy and myself have had problems before. unfortunately, mike at PLP is unwilling to lend a hand once hes sold the merchandise.. more or less, we are on our own after purchase..

id hate to think its the same deal with his s/c's, especially if someone had a problem with theirs..
That sucks!!... what happen to the "good reps" that Mike has for his good customer service... this is not very encouraging for a potential customer.. :-? :-?
 

·
Registered
Joined
·
1,890 Posts
Re: PLP heatshield...BROKEN...CRACKED...BUZZIN

Master said:
then i took it off only to find that there are cracks where the screw holes were leading to the edge.

sure i've had it for more than a year or so ...but i expect to pay for smtehing that lasts.

i have the first run of heatshields without the sides

i'll post pics later


This is my EXACT situation!! I took mine off last week after having a buzzing noise at low rpm 1000-2000, and it was cracked at the front bolt hole! That noise made me crazy for 2 months and I only just figured out what it was. When you look at the shield, the crack is hard to see, but it was definitely causing the buzzing (due to the vibrations).
 

·
Registered
Joined
·
1,462 Posts
Re: PLP heatshield...BROKEN...CRACKED...BUZZIN

All of these problems have been fixed with the current batch (All seams are TIG welded), and those few people that have issues will be receiveing a replacement for free just like DegoIS has stated, but not if it is over a year old or has been modified infact Anh aka master I installed that heatshield for you back in Sep. 01, you have also been in a front end collision since then. So next time if you truly had a problem why not contact us first? To those little "crews" that like to create negativity within in your own circles you should grow up (nafooesi- I know you are the from the outcast lexstacy group, concentrate on your own ethics)
Dpatterson, you are very wrong, you should not make accusations you cannot back up, you admitted to me it was your fault from trying to force it in and out, right?? The I even offered 40% off to you on any product to make you somewhat happy!
Also, we thrive on customer service and it is priority #1, I believe we are one of the very few Lexus specific companies that can make that statement.
Thank You
Mike
Master said:
so yea i heard alotta buzzin from my engine bay.

so i checked everything else and then narrowed it down to the heatshield.

i loosened the bolts and put them back on tightly but still buzzy.

then i took it off only to find that there are cracks where the screw holes were leading to the edge.

sure i've had it for more than a year or so ...but i expect to pay for smtehing that lasts.

i have the first run of heatshields without the sides

i'll post pics later
 

·
Registered
Joined
·
3,428 Posts
mike,

i also have the gen 1 heatshields- but with my vibration problems, i just put washers on the bolts...however it always eventually gets loose because of the heat.....is there a way you can resolve this?
 

·
Registered
Joined
·
1,445 Posts
Discussion Starter #9
Re: PLP heatshield...BROKEN...CRACKED...BUZZIN

IS Pilot said:
All of these problems have been fixed with the current batch (All seams are TIG welded), and those few people that have issues will be receiveing a replacement for free just like DegoIS has stated, but not if it is over a year old or has been modified infact Anh aka master I installed that heatshield for you back in Sep. 01, you have also been in a front end collision since then. So next time if you truly had a problem why not contact us first? To those little "crews" that like to create negativity within in your own circles you should grow up (nafooesi- I know you are the from the outcast lexstacy group, concentrate on your own ethics)
Dpatterson, you are very wrong, you should not make accusations you cannot back up, you admitted to me it was your fault from trying to force it in and out, right?? The I even offered 40% off to you on any product to make you somewhat happy!
Also, we thrive on customer service and it is priority #1, I believe we are one of the very few Lexus specific companies that can make that statement.
Thank You
Mike

wow first off...i would like to say, my lil "crew" of negativity is not to blame for this topic. i'm merely posting what happened to me. SECOND, i never involved myself in your drama issues. what you have between you and other parties is your own business. in fact, you've always been quite pleasant around me until tonite. at least i'm mature and smart enough to know that. <---cheap shot! :D

second...i'm SURE my "front end collision" of my warped hood and broken bumper was to blame for this. i am not the only genuine case of this occuring.

anyways, if you're not gonna replace it then whatever. i wasn't expecting so since it is kinda old. but again. my other parts that were on my car since day one are still working...and your's isn't. and since this is a public forum...i can take whatever action i want.

here are the pics:





 

·
Registered
Joined
·
1,798 Posts
Maybe thats what has been buzzing and vibrating in my car! :eek: I notice it only after the engine gets hot after some "spirited driving," and it only vibrates in the lower rpm range. Than again, it could be my exhaust hanger banging on the frame since I have a Xerd Racepipe that expands whe it gets hot.
 

·
Registered
Joined
·
4,027 Posts
first off mike, ive had all three different versions of your heat shield.
the first was the really heavy one. something like 5lbs, the one with NO sides, jsut one big piece of heavy metal.

after having that installed, there was a rattle.. even after tightening, it still rattled.. ok, it wasnt that bad, but still enough to annoy anyone who had the rattle. what did i do? i went with PLP again, and got the second version heat shield.

ok, second version arrives along with the K&N typhoon intake i orderd from you too. (which i might add, since it was one of the first, cost a bit MORE AND in which you promised to follow up with the carb cert sticker once it had been tested and approved)
ok, i installed the second shield, ( the lighter version, 1lb, made from three pieces, the sides were both welded on). so far so good for a while.. but then the rattling comes back.
when i took it off, i found that the welds had come undone. my only thought was maybe i had forced it in when i installed it 6 months before??? I was sure that the welds were quality and that it had to be an install error... BUT WAIT! whats this??!! other people are having problems with THEIR HEAT SHIELDS TOO?! specifically with the welds coming undone??? dang, crazy coincidence...
Oh, and not to mention the K&N typhoon intake, which finally became carb certed, only for you to tell me that i had to go through K&N myself to get the carb sticker after you had told me that you would help me out once it came out.. but thats ok.. cuz lets see, i ended up switching to the PLP intake anyways.. but hey, its all good.. (by the way, wasup with the PLP carb cert? will i ever see that sticker?)


ok, no biggie.. i still have faith in PLP.. lets buy their THIRD heat shield..(the one that is 1lb, all made from one piece and welded for "extra security" and has the PLP logo sticker on it)
OK, granted, you did give me 20 percent off on this one.. thanks.. that paid for just a few bucks under shipping costs..
Ok, this shield is much better.. its about time you got it right. FINALLY!
There is no noise from this one, the sticker is still there, hasnt melted off yet.. and so far, everything seems to be holding tightly.

yea, so overall, my opinion of PLP is so so.. granted, i dont spend the big bucks and i havent gotten your S/C.. but i have gotten these things from you:

Heat shield ver 1,2,3.
K&N typhoon intake
PLP intake

sorry im not the hugest consumer of PLP, i just dont have that type of money...

but make of my experience what you will..
 

·
Podiatrist
Joined
·
23,616 Posts
Re: PLP heatshield...BROKEN...CRACKED...BUZZIN

Master said:
second...i'm SURE my "front end collision" of my warped hood and broken bumper was to blame for this. i am not the only genuine case of this occuring.
I was rear ended and the front of my car was pushed into the car in front of me.

On the drive home I noticed a buzzing and it was in fact the same thing that occurred to you. A small crack by the corner of the heatshield. I think there's a strong possibility that your front end collision did this.

My front end wasn't hit bad. The bumper slid underneath the car in front and just barely hit my hood (enough to dent it)

There's my .02 cents.
 
1 - 12 of 12 Posts
Top