Lexus IS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5,107 Posts
Discussion Starter · #1 ·
hey,

an update with my jdm fogs....

over the time that i have had my jdm fogs on the car, i have blow 1 fuse, taken the connections in and out about 20 times....(water issues)

the plugs have now melted, from hb4(oem 2003) to 9006(oem 2002)...had to chnage em up....But here was my mistake i purchased APC high volt bulbs...they kinda match the driving lights but they drew too much power and melted the sockets...and ive been having problem with it ever since....errr... :lol: ....so id always have to kick the lights to get the connection right, pry open the wheel well plastic wall and mess wiht it, blow on the plugs(dry them out) just a pain in the ass...

but to fix them problem i reorder a set of new connection plugs...lex has them for $7 and purchased a set of PIAA 9006 bulbs that are super bright/white/blue...$99 but ill also replace the fuse...and hopefully when i do all that it will come out tthey way i original wanted :0 which i know it will :D ....so ill post up later on it...the plugs are delived on wedensday...and i have the bulbs now...l8ter( plus ill have pics again, like the first time i did it)
 

·
Registered
Joined
·
3,389 Posts
man, sorry to hear about your troubles..
ive had my jdm fogs on for forever now.. no problems at all.
no melted wires cuz i used the right bulbs with correct wattage.
no problems at all.. aside from looking TIGHT! =)

i also had them xpelled new so no rock chips ever... still look as clean as the day i got them..

gotta love the jdm lights at night.. makes the is300 look much different.
 

·
Registered
Joined
·
6,235 Posts
dpatterson069 said:
man, sorry to hear about your troubles..
ive had my jdm fogs on for forever now.. no problems at all.
no melted wires cuz i used the right bulbs with correct wattage.
no problems at all.. aside from looking TIGHT! =)

i also had them xpelled new so no rock chips ever... still look as clean as the day i got them..

gotta love the jdm lights at night.. makes the is300 look much different.
hes got a 03. the fogs are different than the 01s so he had to hotwire some thingmabob to make it work. thats why hes got all the trouble.
 

·
Registered
Joined
·
5,107 Posts
Discussion Starter · #5 ·
baadhabit said:
dpatterson069 said:
man, sorry to hear about your troubles..
ive had my jdm fogs on for forever now.. no problems at all.
no melted wires cuz i used the right bulbs with correct wattage.
no problems at all.. aside from looking TIGHT! =)

i also had them xpelled new so no rock chips ever... still look as clean as the day i got them..

gotta love the jdm lights at night.. makes the is300 look much different.
hes got a 03. the fogs are different than the 01s so he had to hotwire some thingmabob to make it work. thats why hes got all the trouble.
yes yes good show, ur hit the nail on the head, also those crappy APC bulbs burnt the plugs and wires, but now with the PIAA's and new plugs (which come in tommrow)...
 
1 - 7 of 7 Posts
Top