Lexus IS Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey guys I just purchased an 03 is300 factory 5speed and I’ve been having issues with it in limp mode. Trac off flashes every 3 seconds or so, no check engine light but when I went to check for codes I had P2102. Throttle Actuator Control Motor Circuit Low. I’ve been suspecting the throttle actuator motor going bad but how do I test it? It buzzes or hums when I have ignition on but engine off, and I have checked if my tps is ok and voltage does increase when throttle opens, I have .68v I believe at idle. At this point im lost and my is300 is my daily driver which means I’ve been driving it for quite a while in limp mode. I would very much appreciate some help! Thanks all!!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Run across that before. Replace it. It is bad.
So I just replaced the throttle actuator motor, still no luck I am close to giving up right now. It should start right up with no trac off flashing lights even without calibrating the tps right?
 

·
Registered
'01 Lexus is300 JTHBD182X10007711
Joined
·
1 Posts
The only time my is300 put me in limp mode/ TRAC OFF light flashing is when I had to change the THROTTLE BODY! Is your ABS light also on the dash?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
No only trac off is flashing, also my idle is 1800 rpm and it doesnt cold start. Already tried adjusting tps to .65v and also replaced the throttle control motor. Help plss
 

·
Moderator
Joined
·
4,742 Posts
So when you replaced the throttle control motor. Did the 2102 go away or unchanged? Also di you use a new part or used? Who installed it? I also want to make sure this is your only code?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
Havent checked code yet but I believe its still the same. And yes second hand motor but i Believe it was good because the motor had no friction when spinning unlike the one I replaced. I installed it
 

·
Moderator
Joined
·
4,742 Posts
Okay, There is a way to power the motor manually to make sure it open correctly. I think there is a video on YouTube. I would look to do that and make sure on the codes.
 
1 - 11 of 11 Posts
Top