Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
Ok so before everyone starts getting mad about searching I did . Many times... So here's my issue
So in the beggining in the morning when it's cold or wet I start my car and itl idle high at about 1800 to 2100 and when I press the gas it will be empty till about last cm from the floor anyway il drive around well try to let it get hot restart the car and then I have a normal gas pedal and no limp mode feeling.
So I changed my entire tb and set the tps to .68 v now it doesn't idle high but the throttle issue still happening . I scanned it got the p1126 magnetic clutch malfunction so idk what to do if its a wiring issue ecu or trac.. Btw trac light is flashing and check engine is on .. Any help and how to test would be great ty
 

·
Super Moderator
Joined
·
19,540 Posts
You replaced the throttle control motor as well? That's the problem. The throttle control motor is always spinning and is the hum you hear when you hit the accelerator with just the ignition on. There is a clutch that grabs the throttle gears and constantly engages and disengages.

This code is set when...
-theres an open or short in the magnetic clutch circuit
-throttle control motor is bad
-ECM issue

You really need an oscilloscope to see the way forms from the ECM.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #3
I bought a whole new throttle body with all the sensor.. And idk it's getting frustrating always feels like its stalling... And just out of curiosity would voltage issues have a role to play?
 

·
Super Moderator
Joined
·
19,540 Posts
I bought a whole new throttle body with all the sensor.. And idk it's getting frustrating always feels like its stalling... And just out of curiosity would voltage issues have a role to play?
Battery or charging system voltage? Possibly, but other issues may occur. DTC P1126 means the clutch current is out of range and the ECU interprets this as a fault and the butterfly closes/DBW fails. That would explain why the car runs in limp mode. The ECU monitors both the magnetic clutch current and the TPS voltage to confirm proper operation. If the TPS value does not change when the throttle motor moves, the ECU will conclude the magnetic clutch is stuck.

Make sure your accelerator pedal cable allows the sensor's spring loading wheel be at rest. You really need freeze frame data to watch the clutch current variate. Current is always between 0.8 to 1.0 amp. Clutch wires should read 4.2-5.2 ohms @68*F(terminals 3 and 4-two towards firewall). Motor should read 0.3-100 ohms @68*F. The problem can also lie in the wire loom back to the ECU, so that wiring can be checked. When you have the ignition on only and hit the accelerator pedal, the TCM starts humming. TPS voltage on VTA to ground should be about 0.65v. Also, i hope the TCM was installed correctly. There are protrusions that make proper alignment nessesary.

All connector E7(fifth one from front of car)
clutch
pin 10 red/white CL+
pin 9 yellow CL-

motor
pin 3 white M+
pin 2 red M-
 

·
Registered
Joined
·
122 Posts
Discussion Starter #5
Ok we'll it's late now il go through everything but I noticed I can force a dead pedal... If I increase voltage load heat wipers defrost high beams and bass my car throws the code and sounds like I'm about to stall everything dims and no throttle.. E dry time I increase cars electric load it happens so I guess il change battery ECM and switch back to oem alt tomorrow .. So il keep u guys updated because allot of people have this issue with no way to fix
 

·
Registered
Joined
·
2 Posts
Ok we'll it's late now il go through everything but I noticed I can force a dead pedal... If I increase voltage load heat wipers defrost high beams and bass my car throws the code and sounds like I'm about to stall everything dims and no throttle.. E dry time I increase cars electric load it happens so I guess il change battery ECM and switch back to oem alt tomorrow .. So il keep u guys updated because allot of people have this issue with no way to fix
So what did you end up doing, I got 1126 as well
 
1 - 7 of 7 Posts
Top