Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I looked up this code on here and all people are saying is to replace this sensor.. first I started off with P0031 and P0037 .. I replaced both Bank 1 sensors trying to get rid of the check engine light.. now P0037 came back.. I have all brand new Denson sensors and a brand new Lexus sensor for bank 2 sensor 2.. mechanic said that I might get p0037 again after he fixed it and I drove off and there it is again..! is it the wiring harness or maybe a faulty sensor? I just got a full new exhaust and I'm tired of still have a check engine light on. Please help!
 

·
Cherisher
Joined
·
4,800 Posts
^ same question. Stock or aftermarket?

I have the same code and picking up the sensor tomorrow.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
Pace setter exhaust manifold, Denso sensors, Megan racing y pipe, Greddy Revolution RS (new version).. I actually got the light fixed the sensor was in the wrong bank ? Now I finally got it to pass emissions!
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Thank you for the help.. I fixed it now though.. all sensors should be fine no check engine light and got it to pass emissions
 

·
Registered
Joined
·
26 Posts
Discussion Starter #7
Mine was in the wrong bank lol.. car drives sooo much better just with a new sensor lol.. maybe yours is faulty I guess it happens more than you think.. Denso ones come with like 1 year warranties
 
1 - 7 of 7 Posts
Top