Lexus IS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
Hey guys, I have been long overdue to replace my harmonic balancer (didn't realize how bad it was until a couple weeks ago, it's absolutely destroyed). I got it uninstalled tonight and noticed that is is significantly smaller than the new one. The old one is 4.5" in diameter and the new one is 6". I double checked and I did order the right part, the one that was on the car is not a stock pulley. However, it doesn't look like a typical aftermarket underdrive pulley, it looks OEM. It's also significantly lighter since its smaller. What could this part possibly be from? It was installed by the previous owner so I have no way of checking. Has anyone heard of this or know what part # it is? Looks like I'm going to have to get a new serpentine belt since the new pulley is so much larger. I'm kind of hesitant to install the new balancer and lose a bunch of power from the added weight. I have some pics below showing the difference in size.

Old balancer:
134149


New balancer:
134150


Comparison pics:
134152


134151
 

·
Registered
Joined
·
57 Posts
Discussion Starter #3
That is what they look like whin the pulley is removed. It looks like someone ran it with the pulley removed.
That's exactly it, good call. I didn't know you could even remove them, don't know why someone would do that. Hopefully my engine isn't trashed, it's been running fine the last 40k miles I've put on it.

Side note, I got a new serpentine belt and it doesn't fit. So I'm not sure what's going on there, maybe one of my other pulleys is messed up too? Time to measure them all and see what's going on, but for now I'm gonna throw on a slightly longer belt so I can at least drive it.
 

·
Registered
Joined
·
2,548 Posts
That's exactly it, good call. I didn't know you could even remove them, don't know why someone would do that. Hopefully my engine isn't trashed, it's been running fine the last 40k miles I've put on it.

Side note, I got a new serpentine belt and it doesn't fit. So I'm not sure what's going on there, maybe one of my other pulleys is messed up too? Time to measure them all and see what's going on, but for now I'm gonna throw on a slightly longer belt so I can at least drive it.
Make sure it is routed right and they have the right tensiorner and pulleys.
 
1 - 4 of 4 Posts
Top