Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought an 04 IS300 about 2 weeks ago and all was well until couple days ago. Whenever I first start the car when its cold there is a noise behind the dash, sounds like it coming from the middle of the dash and it sounds like someone is on a type writer just going to town kinda like a clicking noise. After about 5 mins its goes away and doesn't do it anymore. Any idea's? I am pretty mechanically inclined but I am stumped. Only guess I have is air in the AC system. I also read on another forum something about a servo, but Im not sure what that is.
 

·
Registered
Joined
·
835 Posts

·
Registered
Joined
·
99 Posts
There are servo's/motors behind the dash that direct the airflow and help adjust temperature. There are several posts on this. You can figure out which one is the problem by adjusting the temperature dial and the mode dial to see which one is causing the clicking.

Some people had luck in that some lubricant and a cleaning helped, I had to replace mine.

One poster (?Froggy) actually did a pretty good you tube video of how to check and replace them.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Appreciate the help guys. Mine is the gurgling noise (air in the system). I am going to bleed the system and see what happens. Luckily its not the servo motor.
 

·
Cherisher
Joined
·
4,800 Posts
Appreciate the help guys. Mine is the gurgling noise (air in the system). I am going to bleed the system and see what happens. Luckily its not the servo motor.
haha, glad my post didn't go to waste then... the gurgling was still my first thought ;)
 

·
Registered
Joined
·
229 Posts
First thing I would do is put more Rad Fluid and let the motor run and bleed the system by letting all the air bubble out. Then you should be fine.
 
1 - 7 of 7 Posts
Top