Lexus IS Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
ok so I was heading back home from a trip when right after I fueled up my IS350 with 93 octane, I always check, started shaking a lot, lost about half its power, the "Check VSC" "Check Engine" and "Traction Control" lights came on... I had it towed back to the dealer and they told me it got bad fuel, so they flushed the gas tank and it was working fine... until a few days after, it did the same thing, so I turned it off and when I turned it back on the problem was gone... I got my car up to 6500 rpms and it started doing it again, and lexus is telling me that they need me to put in about 1G so they can see what is wrong with it... I drove the car on the "bad fuel" for not even a quarter mile and they're speculating that the whole fuel system was affected, how ever I do not understand how it runs fine with normal driving but when I decide to have fun with it it wont perform as well... I guess my question is, has this happened to any one else? If so, do you know what can be done to fix it? Is the dealer right in wanting me to waste more money and time on it or are they giving me a run around?? any help would be greatly appreciated!! thanks
 

·
Registered
Joined
·
330 Posts
it could be alot of things, i had the same problem, turned out it was just my fuel cap, but it could be ur valves, or it could be a sensor...chances are if you drive your car only a 2 or 3 miles in ur commute, u have gas in ur oil, unscrew ur oil cap and take a wiff, if it smells like gas, then u need ur oil changed...ask the dealer what the code is, it should be on the paper they gave u
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top