Lexus IS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
hey, i have a 2001 is300 and my sunroof cover doesnt close all the way. when i close it, it only closes half way, not all they way like its suppose to. can anyone help me to solve this problem. thanks

 

·
Registered
Joined
·
7,236 Posts
are you talking about the sunroof glass it's self or the fabric cover? if it's the glass you should open the sunroof all the way and put some grease along the rails :confused:
 

·
Registered
Joined
·
1,509 Posts
i know that when i had a maxima underneath the switch panel for the sunroof controls there was a screw to manually shut it. not a permanent fix but it will shut it in the meantime if we have that as well?????? worth a shot. GL
 

·
Registered
Joined
·
3,015 Posts
happened to me, i was under warranty and was able to get it replaced for free. the fabric was bunching up under neath preventing..

ur going to have to take the head liner off and check
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
its the fabric cover that is stuck and its not like u can try to push it and its ok, its like something is on the way. every time i try to open it all the way, theres something solid not letting it go all the way. and if i take the head liner off, i dont know where to start from, like what to take off and stuff.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 · (Edited)
never mind guys... i took the trim off the sunroof and took off the light switch... then i used a flash light to see what was not letting me open the fabric cover all the way... then i saw that there was a bar that was bent upword... the bar is in the back seat, right above it... like maybe some one hit their head there and bent the bar... lol.. but the bar isnt really solid, so i was able to push it back down to so it wont be on the way of the sunroof cover... the cover slides right on top of the bar, thats why it was blocking it... it only took me like 20 minutes or so and im good now... it was really simple what was wrong with it... let me know if any of you guys need any more details or any help if anything....



thanks, IS300_BLK
 
1 - 6 of 6 Posts
Top