Lexus IS Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys Im new to the Is scene , so I bought a 2001 Is 2 weeks ago and it dosent rev over 3000 rpm is stays at 3k RPM (even if u floor it) and then shifts. I took it to a tranny shop and they sead the tranny was good. One of the guys at the shop told me that is could be my ECU ? does the 2001 is have a separate computer just for the tranny ? And it also had a CEL but whenever i would hook it up to a scanner it would never connect to the scanner any Ideas why ? :confused: I just managed to erase the CEL for a little while.
 

·
Registered
Joined
·
960 Posts
Take a rubber hammer and tap the cats in the y-pipe and headers. I had the same problem and it turn out to be a clogged cat in my headers. If it's a bad cat you will hear a high "TING" sound. If it's a deep thump sound that the cat is still good.
 

·
Super Moderator
Joined
·
19,540 Posts
A bad MAF will cause this too. See if you can read airflow on a scanner. Check your OBD fuse otherwise it said it "wasn't ready" because you had just previously erased the code. The scanning of the sensors resets after x many miles and x many startups. Don't erase them until you know what they are. They will lead you to the problem.

Edit: You could also be in limp mode and have a bad positioning sensor. Here is another same issue but was MAF. http://my.is/forums/f115/2001-wont-rev-past-3k-rpms-when-computer-reset-422425/

Need codes plz.
 

·
Registered
Joined
·
34 Posts
pull the battery for a little that happened to me when the clutch solenoid froze so reset it. see if that works if not bake your car with a torch if ur brave enough and check all your fluids. sounds like ur car is in safety mode. but usually cpu reset will do it.
 
1 - 5 of 5 Posts
Top