Lexus IS Forum banner

1 - 20 of 118 Posts

·
Registered
Joined
·
5,941 Posts
Discussion Starter #1 (Edited)
Got my manifold, turbo, downpipe, oil feed & return, intercooler & piping, IK24 plugs, and injector clips installed.

Need to install the injectors, fuel pump & return kit, Blitz SBC, EFI 1000 wideband, and TEC3.

I ran into a few problems so far, removing the stock exhaust manifold and y pipe was a pain in the ass. Damn bolts wouldn't want to break loose and the O2 sensors didn't want to come out either. I cracked my fuel rail when I tried to tap my 1/4 NPT fitting. I was missing an intercooler piping and another piping had the HKS BOV flange welded on the wrong area. I was missing 2 exhaust gaskets. My TEC3 is missing 2 bolts to secure the trigger wheel adapter. Looks like I might be able to finish if I'm lucky late Thursday night but more than likely this weekend.

Ok pics from the install...











My S4 crew comes to help out.





Also what O2 sensor did everyone plug into their downpipe? Did you use the one of the pre-cat or the post-cat?
 

·
Premium Member
Joined
·
5,207 Posts
Looking good +rep for the boost update.
 

·
Registered
Joined
·
8,219 Posts
Lambchop, if my memory serves me correctly, use the post cat 02 sensor for bank 1 sensor 2 on the downpipe, then the 02 bung under the car is the old y pipe sensor which is bank 2 sensor 2.. The 2 sensors that plug in near the water pump should be completely unplugged.
 

·
Registered
Joined
·
5,941 Posts
Discussion Starter #6
Malekreza11 said:
Lambchop, if my memory serves me correctly, use the post cat 02 sensor for bank 1 sensor 2 on the downpipe, then the 02 bung under the car is the old y pipe sensor which is bank 2 sensor 2.. The 2 sensors that plug in near the water pump should be completely unplugged.
Ok, so the O2 that's plugged closest to cylinder 6 should go into downpipe and the two that are plugged closest to the water should be unplugged completely. Many thanks Malek.
 

·
Registered
Joined
·
3,533 Posts
looking good Leo. Props to you for installing this at home

let me know if you need anything from BL ;)
 

·
Podiatrist
Joined
·
23,616 Posts
The car uses the pre-cat 02 sensors more than the post-cat.
I would put a pre-cat 02 sensor in the downpipe.

Come on Leo. Think with your dick more. It'll work out better that way.
 

·
Registered
Joined
·
2,236 Posts
leo, for the dp o2 sensor, i am using the one that has a wire clip (plastic)to it. so, whichever o2 sensor that is cliped on here:


good luck!
 

·
Premium Member
Joined
·
4,548 Posts
lambchop11078 said:
Ok, so the O2 that's plugged closest to cylinder 6 should go into downpipe and the two that are plugged closest to the water should be unplugged completely. Many thanks Malek.

Jusat confirming with you that Malek and De are correct.

Looking good so far! Mind me asking how much you paid for the kit?

If you have any questions regarding the Tec3 tuning, ask either Malek or I.

Kane
 

·
Registered
Joined
·
3,533 Posts
yea...leo had a long wait for his parts to arrive

how long did it take for your parts to arrive?
 

·
Premium Member
Joined
·
4,548 Posts
BigDaddyRich said:
You need at least one of the Sensor 1's in the DP. whether it be Bank1 or Bank2.

Damn almost a year for a BL kit to be running :)
Not if he's using a Tec3 with the PFS box, they use O2 sims for the first two o2 sensors.

If no PFS box or equivalent, then you are correct. But I believe the BL kits that sold with Tec3 also came with a PFS box or equivalent.

Kane
 

·
Registered
Joined
·
5,941 Posts
Discussion Starter #14
Kanine21 said:
Not if he's using a Tec3 with the PFS box, they use O2 sims for the first two o2 sensors.

If no PFS box or equivalent, then you are correct. But I believe the BL kits that sold with Tec3 also came with a PFS box or equivalent.

Kane
Don't got the PFS black box. Just the PFS version of the TEC3.
 

·
Registered
Joined
·
5,941 Posts
Discussion Starter #15
Kanine21 said:
Jusat confirming with you that Malek and De are correct.

Looking good so far! Mind me asking how much you paid for the kit?

If you have any questions regarding the Tec3 tuning, ask either Malek or I.

Kane
I originally paid $6999 for the kit, it was suppose to have the TEC3 but then I received a Haltech E8 and MSD DIS-4 instead. Due to some issue with Toyomoto not giving the wiring instructions and base map, I sent the E8 and MSD back and got a refund of $2200 so the hard pipes were $4799 plus the price of a used TEC3.
 

·
Registered
Joined
·
20,661 Posts
^^ damn good price right thuuurrrr.....

let us know when you get this bish running
 

·
Registered
Joined
·
3,533 Posts
tsopranoMB said:
^^ damn good price right thuuurrrr.....

let us know when you get this bish running
i never said the BL kits were expensive to begin with ;)
 

·
Registered
Joined
·
2,278 Posts
stupid but why is the vvti left unplugged?
 
1 - 20 of 118 Posts
Top