Lexus IS Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Took my 02' 5sp a couple months ago to California Speedway street drags and could only muster a best of 15.87 on 5 passes, most of the time I was lucky to break 16.00 seconds. Some of you thought I should run low 15's or might break into the 14's with mine being a 5sp. SO WHAT GIVES?
Do these cars need a S-AFC to get them to really come alive with some mods? Because I sure was getting tired of seeing civic / accord tail lights when I was the one cutting the better tree light.

(track info. Altitude around 1000 ft., 95 degree track temp.)
(Car mods. JoeZ intake w/TRD filter, Megan racing pipe, HKS Hyper exhaust).
Thanks for the input...........Bob
 

·
Registered
Joined
·
2,291 Posts
Can you post a time slip? What where the trap speeds?
 

·
Banned
Joined
·
468 Posts
the problem is your underpowered overweigth 2jz.
i ran mid to low 14's when my 3SGE was stock with just an intake and exhaust.
boost your car and you will be alright. good luck
 

·
Registered
Joined
·
2,291 Posts
Tarik said:
the problem is your underpowered overweigth 2jz.
i ran mid to low 14's when my 3SGE was stock with just an intake and exhaust.
boost your car and you will be alright. good luck
Tarik, read what he wrote and read what you wrote. Now ask yourself did you help him out at all? :suspiciou
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Sorry don't have the time slips, I was SO DISAPPOINTED I chucked them. But If I remember correctly around 90 mph....
 

·
Registered
Joined
·
1,396 Posts
bad launch? or possibly extra weight in the car? I pulled off a 15.6 bone stock with the gf in the car and a trunk half full. So eh maybe you need a tune up
 

·
Registered
Joined
·
982 Posts
Are you on stock wheels?

I ran my 01 a 15.4 with 19's. I had a HKS exhaust and a K&N FIPK intakes, plus it was in Febuaray and the weather was 28....
 

·
Registered
Joined
·
1,945 Posts
something must be terribly wrong cuz I think stock civic are in the 16's.. Not to burst your bubble or stick up for Honda's(Even though I had one and still somewhat a Honda Head) some of those Honda's are no joke. Some of the bad boys can put down some serious #'s. I'd definelty check something out though. Tires do make a diff on the track though.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #11
TRM3 said:
Are you on stock wheels?

I ran my 01 a 15.4 with 19's. I had a HKS exhaust and a K&N FIPK intakes, plus it was in Febuaray and the weather was 28....

Yes, I ran on stock wheels & tires (Dunlop's)
 

·
Registered
Joined
·
19 Posts
Discussion Starter #12
toyotaownsyou said:
i bet you just need to learn how to launch.......what were your 60' times......

Can't remember my 60 foot times. I was at times getting some tire spin, Not the best track I ever raced on!
 

·
Registered
Joined
·
1,135 Posts
02IS4ME said:
Thought of that, on my 3rd pass I even took the filter completely out.

wow, that is pretty bold considering the filter is to keep foriegn objects from getting into your engine. It sounds like you were a little desperate. If you got a lot of wheel spin, next time try burning them a little longer so you can heat them up for traction.

I would say that might need a tune up as well.
 

·
Registered
Joined
·
411 Posts
Hmm without seeing the time slips and being able to look at those its hard for us to tell you what's going on. But a 15.8 seems very high. When I was at the track a stock e shift was doing 15.6-15.7 passes all day long.
 

·
Registered
Joined
·
62 Posts
you might just need a little prctice on the track, I used to go every weekend and got really got at launching and shifting, usually improving in my friends cars by .2 to .4 faster than thier best. Go back a few times and just watch Your tach, Your car and your finish line and your tree. I dont know about the IS but if you learn to slip the clutch a little and keep your revvs in the tourqe band it will help a lot more than you could imagine. I would look for a 2.0 60 in the IS, keep trying and let us know after a couple of weeks. the stock lexus should run about 15.5 @ 90 mph so you are not too far off.
 

·
Not Officially Back
Joined
·
12,742 Posts
cyphertext69 said:
wow, that is pretty bold considering the filter is to keep foriegn objects from getting into your engine. It sounds like you were a little desperate. If you got a lot of wheel spin, next time try burning them a little longer so you can heat them up for traction.

I would say that might need a tune up as well.
Street Tires? No. You gain nothing by doing a burnout on street tires.

02IS4ME: In the future, you need to keep your timeslips or at least remember the numbers... if we don't have that info we can't really tell you what was wrong...
 

·
Registered
Joined
·
911 Posts
did u leave your trac on??? when i left my trac on by accident i ran a 15.8..
 

·
Registered
Joined
·
20,661 Posts
DT2K said:
did u leave your trac on??? when i left my trac on by accident i ran a 15.8..
true....

must make sure TRAC is OFF and PWR is ON
 
1 - 20 of 38 Posts
Top