Lexus IS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
First off, I've used the search function and came up empty handed on my particular problem, plus my scenario is a little different.

2002 IS300 auto to manual swap.

Bought the car a month or so ago and drove it for abut a week before parking to tie up some loose ends. The swap was done correctly using all factory parts from a wrecked manual including the ECU. I'm assuming the only key I have is the OG master key and the person who did the swap took the car to have the manual ECU and OG key linked/programmed to one another because it opened all doors and started the ignition fine for the week I drove it.

fast forward to about three weeks ago... One of the loose ends was swapping the auto wiring harness for a 03 manual harness which was the only thing they did not do in the swap. I installed the manual harness and now the car does not recognize the immobilizer. They security light flashes when the key is installed and the car will not turn over.

Security light did not flash the initial week I drove it and had no issues with the vehicle


-I've pulled the EFI relay and fuse while battery was disconnected
-Starting battery new and charged
-Key fob locks/unlocks the doors and pops the trunk
-Key will rotate in the ignition and the fuel pump will prime
-All lights inside and out work.



Is there a relearn for the immobilizer or a security rest?


Thanks in advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3 (Edited)
Not that you can do. If memory serves me. I think the dealer can. But that may be for non linked stuff.
Thanks for the reply.

A bit of an update... The key had the common problem of being stuck in between OFF and ACC yesterday before I started to crank it so I removed the bezel that recognizes the immobilizer from around the ignition cylinder and left it hanging while I depressed the detent to un-stick the cylinder. After the Cylinder was free I installed the key and that's when I THOUGHT at the time I had a security/Immobilizer issue.

This morning I went down and put the trim bezel back around the cylinder and put the dash back together. After doing so the car recognizes the key and the security light goes off immediately (master key) when I insert it into the ignition. I do this for a living and we all make mistakes when tired and in a hurry.

Moving on. The vehicle will still not turn over and after checking all fuses/relays and giving it some thought I think I know why. The manual ECM is not recognizing a signal from the clutch letting it know that it's depressed and can be cranked safely. I currently don't have the clutch plug or wiring so I'll have to bypass it to get this thing started. Luckily, I printed out all of the pinouts and wiring the other day at work figuring I'd might run into a problem like this and lo and behold here I am needing it.

I'll figure this out and post an update once the problem is resolved.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Fixed!

I removed the Black/White and Black (park/neutral safety switch) wires from EA1 connector on the auto harness, soldered them together and installed them in the same location on the EA1 manual connector which has no wires in the same pin location. Turned the key and the car started like it should and as for now there is NO cell for a speed signal.

Park/Neutral saftey switch wires on Auto EA1 connector.
133584


EA1 connector on Manual harness.
133585
 
1 - 4 of 4 Posts
Top