Lexus IS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
Ok so this happens only sometimes, cold engine, warm engine, it doesn't matter. I will be at a red light, step on the throttle and the torque converter engages and I start moving for a few seconds, then the engine essentially dies for 2 seconds. There isn't anything you can do but wait. Flooring it just makes the tires spin when the motor comes back. It feels like fuel cut or ignition cut.
I have been logging this issue with a datalogger setup I have. I started to log the MAF and it's temperature. It seems that when the car decides to do this engine die mode after a red light, it appears the MAF temp goes way up. THen back down. The duration is probably as long as the motor appears to die. So what's the issue? I have the SRT intake tube with a drop in K&N style filter into the stock box.
The temps here are cold. As in the 12-18's and then the temp jumps to 40's on the datalog chart?!? So it's a false reading for sure. Do I change out that sensor or do I insulate that intake pipe from engine temps? Or any other ideas?
Thanks
 

·
Registered
Joined
·
117 Posts
You say you have the SRT intake installed with a drop in K&N style filter and the stock box right?? No Racing ECU installed??


I believe the SRT needs the racing-ECU installed because of the 3.5 inch intake or your car won't run right according to Swift Racing themselves.Possibly the SRT intake installed by itself (no R-ECU installed) and stock air box/drop in filter might be your problem.They say their R-ECU is designed for their specific SRT intake and filter.Someone else might be able to tell you better GL....
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #3 ·
I suppose it could be like that. But I think all the air in the pipe has been measured by the MAF. With the large temp spikes, I could see the computer thinking too little or too much air has entered the system (not sure which one just yet). It goes into a fail safe mode for a second, cutting ignition to protect itself.

I don't see the tube size being an issue but if someone can prove otherwise, I wanna hear it. There is a Greddy EMU on the car but it's unhooked because I haven't had time to change up the cold start function and in cold weather it won't start. SO it's the stock ecu all the way except O2 similators for secondary o2 sensors.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #5 ·
Thanks for the link and I will get in touch with them. Hopefully they can shed some light, if it's just the sensor being weird or the intake pipe has issues.
Or even if the MAF temp reading can cause ignition cut or some sort of safety shut off.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #7 ·
Doing reading right now to figure how the temp variable works with the ecu. I think I was wrong on intake size. More volume of air and the ecu calculates this based on the programmed size at the factory.
As for other reading...

"As the air enters the intake manifold through the hot wire MAF sensor it cools down the platinum wire, which is heated at a very precise temperature. When the MAF circuitry senses the platinum wire cooling down it increases the amount of current flow through the hot wire trying to maintain a specific temperature. This varying current flow is then converted to a voltage output signal by the MAF electronic circuitry and is used as an air flow indicator by the ECM. Hot wire MAF sensors have a signal that is directly proportional to air flow. So as air flow increases so does its voltage signal output."

If anyone wanted to know.

I will shoot the guys an email. This has been going on for a while so it's just more irritating that anything. But I will also clean the sensor again to see if that can clear it up. It didn't before.
Hope I'm on the right track as this was originally diagnosed as a Greddy EMU issue, speed sensor issue and transmission issue with it's electronic shifting.
Was thinking it could be the throttle body or something but it checked out to spec.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top