Lexus IS Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3,786 Posts
Discussion Starter #1
I had my car lowered a couple days ago and I get home tonight and notice that the rear passenger side is SLAMMED to the ground. I mean it's almost rubbing the fender. I dont know what happened
 

·
Registered
Joined
·
2,162 Posts
possibly that the springs aren't seated correctly in the perches? who did the install?
 

·
Premium Member
Joined
·
2,767 Posts
it took my car a few days to settle after i put the new springs in. They probably just settled to where its gonna ride.
 

·
Registered
Joined
·
3,786 Posts
Discussion Starter #5
Ok... this is strange and I WILL post pics a little later, but this is what happened.
I get out of my car, turn to check my nice drop and I see that one side is SLAMMED to the ground. I tell me roomate to come out and take a look (he owns a turbo IS300). He tells me to back up a little. I watch his face as I'm backing up and he just grimises, and tells me that it wasn't installed right or that the spring gave out (?).
I call my friend today that helped me install the springs. He asks me if it's drivable so I drive down the road and when I'm done I park on the concrete road AND NOT MY GRAVEL DRIVEWAY ;) The car is sitting fine.
Pics coming soon. My car looks like it's on bags in the pic.
Thanks for the help guys, anyways :)
 

·
Registered
Joined
·
3,786 Posts
Discussion Starter #6
This is what it looked like lastnight:

This is what it looks like on level ground:

And another (with painted fogs):
 

·
Registered
Joined
·
4,826 Posts
So it just looked like that in one spot? My car looks like this as well when I'm on a driveway, since it is sloped. As long as the car look leveled on even ground, you should be fine.
 

·
Registered
Joined
·
2,467 Posts
+ what springs are you using?
 

·
Registered
Joined
·
3,786 Posts
Discussion Starter #9
badxIS300 said:
+ what springs are you using?
Tenzo... I figured they will hold me off until I can get coilover money. haha.
The ride is surprisingly good considering the price of them.
I think I paid like $130 with shipping included and I put them on myself so I didn't spend too much at all.
 

·
Registered
Joined
·
210 Posts
just got mine aligned on s-tech with two fingers wheel well gaps all around. can't get it to factory spec but with in factory spec though.

urs pretty slammed...looks more than 2" prolly not including the load too in the car heh heh...


:wtf: wtf are you talking about Willis???
 

·
Registered
Joined
·
3,786 Posts
Discussion Starter #11
Flipside408 said:
just got mine aligned on s-tech with two fingers wheel well gaps all around. can't get it to factory spec but with in factory spec though.

urs pretty slammed...looks more than 2" prolly not including the load too in the car heh heh...
I weigh all of 145 lbs. My roomate on the other hand is 240 maybe? So I worry when he's with me.
 

·
Registered
Joined
·
3,591 Posts
That looked kinda good slammed.
 

·
Registered
Joined
·
745 Posts
HondaSchmonda said:
I weigh all of 145 lbs. My roomate on the other hand is 240 maybe? So I worry when he's with me.
Don't let that fat ass mess up your ride! ;)
 

·
Registered
Joined
·
1,573 Posts
HondaSchmonda said:
I weigh all of 145 lbs. My roomate on the other hand is 240 maybe? So I worry when he's with me.

cooome on you know it was the fat chick in the back tossing around trying to find the Mcnuggets she dropped :lol:

jk man hope it works out for ya
 
1 - 19 of 19 Posts
Top