Lexus IS Forum banner

1 - 14 of 14 Posts
Joined
·
37 Posts
Discussion Starter #1
I think my cars on limp mode. Revs won't go past 2.5k, stuck at 20/30kmph.
Cleaned the MAF, in fact I replaced it recently earlier this year.
Changed out all 4 o2 sensors over a month ago.
Just changed the diff fluid, transmission fluid and power steering. It was fine after that, although I suspected it wouldn't shift to third gear, but when I went to turn it on again the second time, still the same issue.
I also hear weird grinding/clunky noises from time to time from beneath the car when driving
NO Cel, and throwing no codes either
 

·
Registered
2002 Lexus IS300
Joined
·
864 Posts
Any pending codes?
 

·
Registered
Joined
·
987 Posts
You can still get codes thrown without the cel coming on, just depends on what the ECU determines as critical or not. Best if you can plug a code reader in and know for sure.
 
Joined
·
37 Posts
Discussion Starter #8
You can still get codes thrown without the cel coming on, just depends on what the ECU determines as critical or not. Best if you can plug a code reader in and know for sure.
Update. I disconnected the battery last night and reconnected it this morning. I drove it around the block and it shifts to third and fourth gear without making any sounds, but not fifth. the engine has a roaring sound and won't rev past 2500
 
Joined
·
37 Posts
Discussion Starter #9
Second update. Just went for a longer drive, the car shifts in manual mode but not in automatc, it stays in gear 2. I was able to reach upto 80kmph, but i couldn't get uphill very well. The cars engine still sounds like it's roaring, much louder than usual
 

·
Registered
2002 Lexus IS300
Joined
·
864 Posts
If you have a scanner capable of reading PENDING codes please try that. Most scanners will ONLY read stored (ie CEL light is on) codes.

It seems like you have a possible shift solenoid failure or speed sensor failure. Does your Speedo work?
 
Joined
·
37 Posts
Discussion Starter #11
If you have a scanner capable of reading PENDING codes please try that. Most scanners will ONLY read stored (ie CEL light is on) codes.

It seems like you have a possible shift solenoid failure or speed sensor failure. Does your Speedo work?
No I don't have a scanner unfortunately. and when my mechanic used the scanner it didn't throw up any codes. The speedometer works fine
 

·
Moderator
Joined
·
3,363 Posts
Even if the tranny does not shift. That will not stop it from going above 2.5k.. It sounds like the stepper motor on the throttle body. Or a bad TPS or APP sensor.
 
1 - 14 of 14 Posts
Top