Lexus IS Forum banner
1 - 20 of 68 Posts

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #1 · (Edited)
Hey, so I just bought a used SRT intake and started installing it. Everything is fine, except for the tube the runs from the filter to the sensor. All I really need is a couple good pictures of exactly what needs to be done. The stock tube is too short and too big of an opening to fit the elbow (the comes out of the top of the filter) and the one that was sent to me is too short and too small (too fit over the sensor). Please, if anyone could get some pictures for me I would really appreciate it. Thanks in advance and +rep to anyone who can help me out.

It's step #14 on the instructions if that helps out.

***pictures on post #24
 
  • Like
Reactions: VietHoang

·
Premium Member
Joined
·
10,782 Posts
Okay...But I dont remember what Step #14 is. Sorry. Maybe you can photoshop it, to show what your talking about ;)

EDIT: I think I just understood what you typed. See in the 3rd pic. You want to make sure that the MAF sensor fits with the screws. It only fits in one direction. Also make sure that the longer part of the smaller tube is towards the filter. So that the MAF bracket is on the shorter part of the smaller tube and thats where the coupler goes ;)
I hope this helped. (like I said, its been a while, and its to damn cold now, to go out and take apart my intake)

P.S. You dont have to give me rep. I have enough already. But I will take some tea :p

1

2

3
 
  • Like
Reactions: LexDymndz

·
Premium Member
Joined
·
10,782 Posts
Didnt you just buy it, and you got it that quick? WOW :jawDrop:
 

·
Premium Member
Joined
·
10,782 Posts
If it was all pictures. BAM he would have it installed by now.
Since its in writing, he has problems. He is a contractor :lol:
 
  • Like
Reactions: BBAtl6

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #6 ·
not a contractor...architect....so i'm all about drawings and visual stuff haha

but i don't know what's with me and initial install problems...as long as they end up working in the long run it's fine with me haha. by the way, i went out and drove w/o the tube connected and it is fine. i'll just figure out a solution tomorrow i guess.

by the way, it isn't the maf...it's the tube the coes through the heat shield and connects to the filter

thanks for the pictures though...tea is coming your way soon
 

·
Registered
Joined
·
650 Posts
not a contractor...architect....so i'm all about drawings and visual stuff haha

but i don't know what's with me and initial install problems...as long as they end up working in the long run it's fine with me haha. by the way, i went out and drove w/o the tube connected and it is fine. i'll just figure out a solution tomorrow i guess.

by the way, it isn't the maf...it's the tube the coes through the heat shield and connects to the filter

thanks for the pictures though...tea is coming your way soon
i bought my intake used and the filter was shit. so i bought a new one and it didnt come with that nipple thingy at the top of the filter. so i just didnt bother hooking that hose up and my car runs fine. i dont think its something you have to do. someone told me its to reserculate air to your gas solinoid??? idk what the hell that is. lol
 

·
Registered
Joined
·
650 Posts
one trick i learned w/ the hoses if ones too big use the smaller one... cut a small piece off and put that on the nipple then put the bigger one over it.
 
  • Like
Reactions: BBAtl6

·
Registered
Joined
·
7,236 Posts


if you notice it's mounted on the heat shield so do that first. if the vacum hose is too short then go buy a longer one and then just cut it to size... hope thats what you were confused about
 

·
Premium Member
Joined
·
10,782 Posts
^^^^^Yeah, I mounted mine onto the heat shield. Since I had an extra nut/bolt. Perfect size and all. Woot :)

If you want, I will have that extra tube. I just got a set of new red tubes in the mail. I am going to replace that black one, for the red one ;)Let me know and I will ship it to you.

Ive heard of peeps, poking a hole and feeding a tube through it. Ive even heard of peeps removing the duck bill.
I would recommend using everything that SRT sent. And dont modified the kit :p
Dont listen to anyone about cutting that cover thats on the heat shield. There is a reason thats there. Did I just make sense :suspiciou
 

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #11 ·
oh you're makin sense :p

i think i got it to work today. I moved that thing to the heat shield just like you did and used the stock tube. i hope it stays on, but if not, i'll let you know if i want that tube. thanks!
 

·
Premium Member
Joined
·
10,782 Posts
Oh, your using the stock tube. I understand why its short now and you were having problems with it. My SRT came with a longer hose.

Let me know. Its free :p
 

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #13 ·
well the guy i bought it from sent me another tube that he apparently cut shorter, because it's too short also. so i just figured i'd save the hastle and keep the one on there. you can still send it if you want haha. i might as well have the one on there that should be on there i guess :bigSmile:
 
  • Like
Reactions: IS3_FTW

·
Premium Member
Joined
·
10,782 Posts
Lets see pics of it. I would like to see some black on black on black engine bay :lol:
 

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #15 ·
i'll take some crappy camera phone pictures tomorrow for you haha

i'll give you a teaser photo of what my engine bay looked like BEFORE though
w/ mazzuri:

pre-mazzuri, but more detail: (notice my rigged heatshield haha)


bout to post this in my for sale thread (which is in my signature)
 

·
Premium Member
Joined
·
10,782 Posts
From the EDIT: AEM intake tube size. I bet you felt a big difference.

Less chrome in the engine is good. That thing is blinging :lol:
Are you using the o2sim?
 

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #17 ·
that's aem, not injen. basically the same thing, though. what's wrong with bling? one comment i got from it was "that looks like some tokyo drift shit." haha

but yeah, i definitely feel a difference with the bigger intake. and yeah, i have an o2 sim. no problems yet, but let's just hope i pass emmissions

after i put it on last night, i drove down the street and apparently woke up some friends that it was so loud haha. i did slam the gas, but still... srt + mazzuri + drager = one freakin loud car. i may be investing and an apexi for that reason...
 

·
Premium Member
Joined
·
10,782 Posts
What about the apexi? I changed my statement. It now says AEM :blush:
 

·
Registered
Joined
·
4,121 Posts
Discussion Starter · #19 ·
haha nice. i might change to apexi because it is the quietest, "most stock," sounding exhaust. it'd make it a bit quieter

oh, and i realized that i don't know how i am going to get pictures of the intake posted because i can't send pictures to me email from my phone since i never have cell service out here. i'll try to figure something out
 

·
Registered
Joined
·
15,872 Posts
haha nice. i might change to apexi because it is the quietest, "most stock," sounding exhaust. it'd make it a bit quieter

oh, and i realized that i don't know how i am going to get pictures of the intake posted because i can't send pictures to me email from my phone since i never have cell service out here. i'll try to figure something out
I just sent you a text...I hope it wakes you up

if you get the Apexi I wanna take the Dragger from you
 
1 - 20 of 68 Posts
Top