Lexus IS Forum banner

Lexus is200 technical and Electrical problems

185 Views 1 Reply 2 Participants Last post by  ill_mannered
Hey everyone!
I started to have my problems few months ago when I was going for a drive and all of a sudden the car started to like shake when idling and it didn’t have any power when I accelerated. So I thought it was a misfire problem or something (I got the P0303 code) and I replaced the spark plugs and oils on the car and went for a test drive. Well it still did the shaking thing and when I shifted from 2 to 3 at around 40kmh it felt like it didn’t have any power or torque. Then I parked the car for like 3 hours and when I came back the car didn’t start it was like the battery was dead (it wasn’t I later checked) and then we tried to start it by pushing and it started but it was like really low idle and then it stopped, then we tried to use jumper cables and it didn’t do anything, it only light up the hazards but they didn’t blink, so then we towed it home and I checked the fuses on the car and the electronic throttle control system fuse was blown and also Starting system, srs system, multiport fuel injection system, and cruise control system fuse, well I went and replaced those and the second I plugged the car battery the electronic throttle control system fuse blew up, and the hazards came back on and didn’t blink. And we’ll here I am right now and I have no idea what to do
1 - 2 of 2 Posts
You have a short something in the wiring. Look at the throttle body wires and connections. Make sure your coil pack connectors are tight and good.
1 - 2 of 2 Posts