Lexus IS Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1 (Edited)
So I bought a used JVC KW-AVX740 unit and I need some help on figuring out how I should install it :rolleyes:

I read the thread about aftermarket HU install: http://my.is/forums/f103/how-complete-guide-headunit-metra-wiring-harness-install-331788/ but was wondering if anyone here has installed the same or similar unit as mine and could help out.

I know I need the JDM Double Din (or Scosche kit) and a Metra TYTO-01 harness to use the stock speakers (I heard people have problems even with the harness sometimes and not sure of quality)

The way I understand it is if I don't want to use the harness I could still use the front speakers but not the rear ones. If so, could I change out the rears and keep the bass (would I need adapters if I went with 6x9)?

Sorry for crappy pics

Working:


Metra:


Installed:


 

·
Registered
Joined
·
7,236 Posts
I would just use the Metra harness... I've used it on both IS300's I've owned and never ran into the slightest of problems. Those that say it gives problems are probably "system freaks" that need everything to be perfect. I'm running the Metra and tapped into my rear speakers for my sub's signal and even though it's not "professional" it's more than enough for me.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
I would just use the Metra harness... I've used it on both IS300's I've owned and never ran into the slightest of problems. Those that say it gives problems are probably "system freaks" that need everything to be perfect. I'm running the Metra and tapped into my rear speakers for my sub's signal and even though it's not "professional" it's more than enough for me.
Thanks! I ordered the harness on eBay hoping it will work perfectly
 

·
Registered
Joined
·
14,829 Posts
The Metra harness had a revision sometime last year, and the new one are suppose to be better.

PS Do yourself a favor and do a search for the Scosche kit ...
 

·
Registered
Joined
·
1,057 Posts
+1 Scosche kit! Only paid $9.99 at Sonic Electronics and used a coupon for free shipping and all that back in November 2012.

Matches up perfectly and I have no complaints. Only thing I had to do is snip/trim three little tabs that are between the kit and the climate controls (this way it's flush between the two).

Here's a pic (not a very good one, but you get the idea):

 

·
Registered
Joined
·
78 Posts
Discussion Starter #7
Wow thanks guys definitely going with the Scosche kit now, looks 100% OEM and from what I can see it fits really well. I hate the JDM rounded edges and the gap that it leaves.... And thats a good pic btw, can clearly see how well it fits :cool:
 

·
Registered
Joined
·
14,829 Posts
Beatsonic will definitely sound better.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #11 (Edited)
So I finally decided to do the Install and even though it is not completely finished I must say, the head unit is really nice and the availability of Aux IN makes it so much easier. I'm pretty happy with the Metra harness. And the Scosche dash kit is awesome! Thanks for that.

Some things that need to be finished and I need help with:

Sorry if some of them are stupid and if it is a lot of questions, I'm doing it for the first time in my life and just want to make sure I do everything right

1. There is a whining noise coming from the speakers all the time, but mostly noticeable when sound is off that seems to respond to throttle.

2. I did not ground the MUTE wire and I assume it is only for bluetooth, which I do not use.

3. I grounded the E-Brake wire (not sure if thats the way to do it) but I'm asking because I tried out a DVD and it plays stuff until the DVD menu pops up and then when I press things it does not let me. Somehow I managed to run a movie but only once.

4. I tapped the ILLUMINATION wire into the stock harness, but did not do the same with the Power Antenna since it was missing from the harness on the HU, would I need to do it for radio reception to work properly?

5. The stock antenna connector was too short to reach behind the HU so I left it unhooked for now until I can extend it(any suggestions?).

6. There are 2 connectors in the back that look like antenna connectors. The bigger one is the antenna? and the smaller one is? Would I be okay with leaving the smaller one unhooked since it does not connect anywhere?

7. When I turn the car on the unit automatically turns on and I can't turn it off, the only thing I can do is turn off the screen, but the lights around buttons will stay on:




Here are some pictures of it Installed: (crappy pics)


 

·
Super Moderator
Joined
·
19,540 Posts
Nice install! Looks great:approve:

I'll try to answer your questions the best I can...

1. Check your grounding of the unit as well as your Metra's gain. Make sure it's not turned up too high. If you have any signal or RCA wiring wiring close to B+ or battery "hot" wire then you can introduce alt noise into the system.

2. The MUTE wire should get grounded to any bolt as well as the PARKING BRAKE wire. Directly from this thread>>http://my.is/forums/f103/how-complete-guide-headunit-metra-wiring-harness-install-331788/

3. The PARKING brake wire does get grounded but it may need pulsed using a relay if your unit requires that. You may need to do the bypass as mentioned in the link(step 1). See if the directions to the unit mention a pulsed ground, usually the PB and MUTE are just grounded.

4. The stock black power antenna wire needs wired in otherwise you'll never pick up any channels. This can be hooked up to the stock ACC wire if needed. It just needs power. The green illumination wire from the stock radio harness gets hooked up to both the new HU illumination green wire and power antenna. Here's a wiring reference>> Http://crutchfield.custhelp.com/app/answers/detail/a_id/5873

5. Check your local auto stores. I was just in Autozone and seen attachments and extensions(looked like small sections male/female with adapters iirc). They should have something that will work from what I saw(was looking for antenna parts for another car). I know I've seen similar stuff at Pep Boys or Advance Auto.

6. There are two antennas on our car, you can use either antenna connector. Whichever one works.

7. Not too sure why it turns on automatically when you start the car. Is that possibly an option that's turned on? I'm assuming you have B+ and ACC hooked up right, none of the other wires should turn the unit on I would think.

Hope this helps some...
+rep on doing it yourself, well done!
 

·
Registered
Joined
·
78 Posts
Discussion Starter #13
Nice install! Looks great:approve:

I'll try to answer your questions the best I can...

1. Check your grounding of the unit as well as your Metra's gain. Make sure it's not turned up too high. If you have any signal or RCA wiring wiring close to B+ or battery "hot" wire then you can introduce alt noise into the system.

2. The MUTE wire should get grounded to any bolt as well as the PARKING BRAKE wire. Directly from this thread>>http://my.is/forums/f103/how-complete-guide-headunit-metra-wiring-harness-install-331788/

3. The PARKING brake wire does get grounded but it may need pulsed using a relay if your unit requires that. You may need to do the bypass as mentioned in the link(step 1). See if the directions to the unit mention a pulsed ground, usually the PB and MUTE are just grounded.

4. The stock black power antenna wire needs wired in otherwise you'll never pick up any channels. This can be hooked up to the stock ACC wire if needed. It just needs power. The green illumination wire from the stock radio harness gets hooked up to both the new HU illumination green wire and power antenna. Here's a wiring reference>> Http://crutchfield.custhelp.com/app/answers/detail/a_id/5873

5. Check your local auto stores. I was just in Autozone and seen attachments and extensions(looked like small sections male/female with adapters iirc). They should have something that will work from what I saw(was looking for antenna parts for another car). I know I've seen similar stuff at Pep Boys or Advance Auto.

6. There are two antennas on our car, you can use either antenna connector. Whichever one works.

7. Not too sure why it turns on automatically when you start the car. Is that possibly an option that's turned on? I'm assuming you have B+ and ACC hooked up right, none of the other wires should turn the unit on I would think.

Hope this helps some...
+rep on doing it yourself, well done!
1. I will definitely check the wires and the gain when I can

2. Will just ground the MUTE then

3. Figured it out, mine does not need the pulsing signal. What I missed was a function on the screen that allowed me to go through the DVD Menu and select Play and all the other stuff, works flawlessly! Except the part where the movie was in French until I set it to English.

4. Will make sure to hook up the Power Antenna

5. Awesome I'll visit some stores and check for the extensions

6. Got it

7. After reading the long manual it seems that the unit is set up this way. It says power on when ignition is on and only talks about turning the screen off but not the whole unit.

And most importantly... I set a background picture as IS300 :cool:

Thanks Jason!
 

·
Super Moderator
Joined
·
19,540 Posts
Sounds like a plan:approve: glad I could help.:)

I'm pretty sure you'll be able to get something to extend your antenna adapter. Just with a simple search I found Autozone and Advance Auto has extensions from Metra.
Audio Install Accessories | AutoZone.com
Something like this 6" one(Metra 44-EC6R) might work good for you, I don't think you need a 48" extension. Haha
http://m.autozone.com/autozone-mobile/en/accessories/Metra-Electronics-Antenna-extension-cable/_/N-2625Z1z141v7?id=296614
Advance Auto has the same one too>>http://m.advanceautoparts.com/mt/shop.advanceautoparts.com/webapp/wcs/stores/servlet/product_antenna-extension-cable-metra_22610282-p?un_jtt_v_cookiecheck=on&un_jtt_redirect

As far as the noise, I realize there's not much room, just make sure the RCS's are away from B+ and ACC as possible and if the Metra gain knob is turned up too high it will amplify any alt whine.

Glad to hear you got your videos to play...in English too! Lol
 
1 - 16 of 16 Posts
Top