Lexus IS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Just installed the JDM black tails from the IS300 store, and the top bulb, the brake light bulb, on the passenger side, is giving me hell. when you turn any of the lights on from the column stalk, the driver side lights up, while the passenger side does not.I am also getting the tail light out idiot light on the gauge cluster. Have any of ya'll with these tail lights had this problem?Keep in mind when you hit the brakes, the passenger DOES light up, and all the other lights work, but it refuses to come on when the lights are on, just going down the road.ANy help would be appreciated.Thanks
 

·
Vendor
Joined
·
4,596 Posts
it is your bulb holmes.

The brake bulb has two filaments, one 4 brake and one 4 the running lights. try changing out the 7443 bulb and see if that helps. or pull it out and look at both filaments (little coiley things in the bulb).

the houseing itself does not create the light of course, so it would have to be electrical.

Fig
 

·
Registered
Joined
·
2,553 Posts
yeah, the JDM Black Tails are just the housing, the bulbs are stock. You probably made something loose when you were changin em.
 

·
Vendor
Joined
·
4,596 Posts
Reznor87 said:
thanks, so i should just mess with them, the wires, until it works right?
mainly I would focus on the socket the bulb plugs into or the bulb itself. Check the contacts on the inside of the bulb connector and make sure they are "sprung" out. The bulb makes contact via several wires leads that are fold down its sides. it compresses the contacts insides the socket to make contact. I would mainly check the bulb itself and replace it.

Fig
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top