Lexus IS Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
632 Posts
Discussion Starter · #1 ·
I have a 2002 e-shift with about 36k miles. I just started noticing a lag when shifting from 1st to 2nd gear, it never happened before. Anyone have the same problem? What are the solutions? Resetting ECU...etc?
thanks
 

·
Registered
Joined
·
6,231 Posts
you can take it to the dealer for an ECU flash.

or, if you want a quick fix... disconnect your battery from the car for a few minutes... that should reset the ECU and you should be ok again.
 

·
Registered
Joined
·
632 Posts
Discussion Starter · #3 ·
IS it as simple as an ECU reset? I dont really understand how the ECU affects the shifting, if anyone can explicate.
 

·
Registered
Joined
·
589 Posts
mine was starting to do the same thing from 2nd to 3rd. Dealer first did the ecu resets and then just ended up giving me a new trany. Gotta love the customer service Lexus provides :)
 

·
Registered
Joined
·
6,231 Posts
I've only had 2 incidents so far with my tranny hesitating before shifting. both times I just unplug the battery for a few minutes...and it's fine.

but then I only have 15,5xx miles, so I'll have to see if it gets worse.
 

·
Moderator
Joined
·
8,849 Posts
jyeh74 said:
IS it as simple as an ECU reset? I dont really understand how the ECU affects the shifting, if anyone can explicate.
Your car has numerous computer systems built into it. A computer controls the engine and transmission. The same goes for the shifting. There is a smart program in it too. It learns your driving habbits, as well as driving conditions (traffic) and shifts respectably. It even controls engine power output.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top