Lexus IS Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
Searched the forums and found nothing relating to this topic so I though I would ask. My Climate control is having issues with the lighting. The outer ring lighting works fine but the inner lights on the buttons dont work and the clock/temp guage is dimly lit and will not display any information. I checked the fuses but have'nt found a blown one yet, any other suggestions?
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
But isnt it odd that the LCD isnt displaying anything on it at all, also the perimeter bulbs of the 3 dails are working, its strange that all 3 inner button lights are out. What im basically describing is that the LCD has no readouts or time on it at all, just a faint glow from each side of it in the OEM amber. Also, the rings around the dials are lit up great, just the inner lights on the buttons for rear window defroster and AC intake do not light up.
 

·
Registered
Joined
·
295 Posts
I just finished closing up my climate control after replacing a bulb that went out. I can tell you the bulb part number for the clock. And I hate to be the bearer of bad news, but the lights for the A/C, fresh air and defrost buttons are soldered in....PITA! Unfortunately that was one pic I did not take when I had everything taken apart. Good luck and hope it all works out.
 

·
Registered
Joined
·
64 Posts
Searched the forums and found nothing relating to this topic so I though I would ask. My Climate control is having issues with the lighting. The outer ring lighting works fine but the inner lights on the buttons dont work and the clock/temp guage is dimly lit and will not display any information. I checked the fuses but have'nt found a blown one yet, any other suggestions?

I had the same problem. But all I did was bang it left and right on the dash near it and it light back up. It might be the plug in the back. Hope that helps.
 
1 - 6 of 6 Posts
Top