Lexus IS Forum banner

1 - 20 of 32 Posts

·
Premium Member
Joined
·
5,207 Posts
Discussion Starter · #1 ·
Thanks to my.is member 300iss for this explanation.
I have seen a lot of threads lately with confusion about o2 sims. How they work, how to hook them up, etc. So here, this is for simulating the secodary sensors:

Secondary sensors are B1S2 and B2S2. These sensors do not affect drivablility, but rather measure emmissions post catalitic converter.

Ok. Ill try to break it down for newbs.

In your car you have 2 sets of o2 sensors. The first set of sensors takes care of bank 1 (cylinders 1-3) and the second set takes care of bank 2 (cylnders 4-6).

The sensors in the car are as follows:

B1S1- bank 1, sensor 1 (reads a/f ratio of cyl 1-3)
B1S2- bank 1, sensor 2 (reads post cat emissions cyl 1-3)

B2S1- bank 2, sensor 1 (reads a/f ratio of cyl 4-6)
B2S2- bank 2, sensor 2 (reads post cat emissions cyl 4-6)

The sensors all have a heater wire and a signal wire in the ecu box. With that all being said, you are wanting to simulate the SIGNAL wires for both sensor 2's, B1S2 and B2S2.

I will make a drawing so it is easier to understand. To simulate B1S2 and B2S2, do this: (2001 models)



(2002 and up models)



In this picture, the black dots are where you solder the connection and the black X's are just taped off. So the only 2 wires that you are cutting are B1S2 and B2S2 signal wires. Leave the B1S2 and B2S2 heater wires alone! And you obviously cut the positive and negative to splice those in.

I hope this helped. Let me know if you have any other questions at all.

If you still get a cel, you might have removed the wrong sensors from your exhaust pipe. Now you should only being running B1S1 and B2S1 in the exhaust pipe with this o2 sim for sensor 2's and remove B1S2 and B2S2 from the exhaust pipe.
 
  • Like
Reactions: sdfontanini

·
Registered
Joined
·
282 Posts
300iss: If we ignore the heater circuit, then the CEL would still come on.

I wire a 25watt 20 ohm (or more ohms if you wish) to my heater circuits.
 

·
Registered
Joined
·
201 Posts
quick question

I installed my o2 sim a while back. I'm not sure how to tell if I did it right. Would the CEL still come on if I don't do anything with the heater circuits?

Right now, there are 2 red LED lights on the black 02 sim box, one light is a steady, glowing red light and the other one is a blinking red light, maybe 3-5 seconds in between.

Did I install it wrong? It seems so simple and it looks like I did it right. :suspiciou
 

·
Premium Member
Joined
·
5,207 Posts
Discussion Starter · #4 ·
300iss: If we ignore the heater circuit, then the CEL would still come on.

I wire a 25watt 20 ohm (or more ohms if you wish) to my heater circuits.
300is left the o2 sensor intact on the car, just hidden away, the sensor is still giving a heater signal, you just need to simulate a good signal for the emissions.

I installed my o2 sim a while back. I'm not sure how to tell if I did it right. Would the CEL still come on if I don't do anything with the heater circuits?

Right now, there are 2 red LED lights on the black 02 sim box, one light is a steady, glowing red light and the other one is a blinking red light, maybe 3-5 seconds in between.

Did I install it wrong? It seems so simple and it looks like I did it right. :suspiciou
A CEL would come on if you removed the sensor entirely and did nothing to modify the heater circuit. If you just tapped the o2 signal and left the heater circuit alone and the sensors are still in the car, you should be okay.
 

·
Registered
Joined
·
219 Posts
I didn't know shit wen it came to O2 sims for the exhaust. Now it's crystal-clear!!!!
Great write-up! I vote to make it a sticky!!! Thanks :approve:
 

·
Registered
Joined
·
2 Posts
I am still confused =\ .. Can we use this if both of the Bank2 Sensors are malfunctioning?? Once we cut the sensor 2's signal wires, where do we solder/connect them to?
 

·
Premium Member
Joined
·
5,207 Posts
Discussion Starter · #7 ·
I am still confused =\ .. Can we use this if both of the Bank2 Sensors are malfunctioning?? Once we cut the sensor 2's signal wires, where do we solder/connect them to?
is this the actual sensor or the heater signal? The heater circuit can be cheated by tapping to the other sensor's heater signal line. The actual signal itself will need to be simulated by an o2 sim if you've cut both.
 

·
Registered
Joined
·
1 Posts
Quick question: I just got done hooking up my o2 simulator. After reconnecting the battery, I hear this constant ticking (5 ticks per second) Does anyone know why this is? It's coming from the fuse box right in front of the battery.
When I turn the key to ACC it stops. It only does it after removing the key.
 

·
Premium Member
Joined
·
5,207 Posts
Discussion Starter · #10 ·

·
Registered
Joined
·
1 Posts
I've got an '02 IS 300 and I'm having a common problem: I see my check engine light is on. It gives me po125 & po430 closed loop fuel ctrl insufficient coolant temp...... catalyst efficiency below threshold (bank2). I need to know where I can find an o2 simulator ASAP for state emissions. I changed the o2 sensors, I gutted out the cat built into the manifold and put in a new high flow under the body with new aftermarket exhaust. Somebody please help me. I'm not having any luck.
 

·
Registered
Joined
·
148 Posts
o2simulators.com . I forgot which one you'll need to get, but if you email them they'll be able to tell ya. [email protected] That's the email they had given on their site...GL

I've got an '02 IS 300 and I'm having a common problem: I see my check engine light is on. It gives me po125 & po430 closed loop fuel ctrl insufficient coolant temp...... catalyst efficiency below threshold (bank2). I need to know where I can find an o2 simulator ASAP for state emissions. I changed the o2 sensors, I gutted out the cat built into the manifold and put in a new high flow under the body with new aftermarket exhaust. Somebody please help me. I'm not having any luck.
 

·
Registered
Joined
·
13 Posts
Sup guys, looking for some CEL help. I got an '01 IS300, It has a Megan exhaust and I am having a po155 o2 sensor heater circuit malfunction. I just installed a SIM on it this afternoon and I still have the CEL. I wasn't sure if I need to unhook an O2 sensor, or install another SIM. Or should I install something else entirely?? Thanks.
 

·
Registered
Joined
·
148 Posts
Sup guys, looking for some CEL help. I got an '01 IS300, It has a Megan exhaust and I am having a po155 o2 sensor . I just installed a SIM on it this afternoon and I still have the CEL. I wasn't sure if I need to unhook an O2 sensor, or install another SIM. Or should I install something else entirely?? Thanks.
Well, I know that my '04 takes a different O2 sim than your '01, but still uses the same principle...You need to keep all O2 sensors hooked up, first off. The PO155 is for a heater circuit malfunction as you had mentioned, but it's also for the primary sensor for bank two...The only way to fix that issue (that I know of) is to replace that sensor 'cause the O2 sim only replaces/bypasses the secondary sensors.
 

·
Registered
Joined
·
15 Posts
I have Megan Racing headers on my car and I had a CEL for B2S2, so I got myself an 02 Simulator and wired it in. Right away, the CEL went away but came back about 3 miles later, I cleared it and once again 3 miles later it came back on. I left all the sensors in the exhaust. Did I do something wrong?
 

·
Registered
Joined
·
148 Posts
I have Megan Racing headers on my car and I had a CEL for B2S2, so I got myself an 02 Simulator and wired it in. Right away, the CEL went away but came back about 3 miles later, I cleared it and once again 3 miles later it came back on. I left all the sensors in the exhaust. Did I do something wrong?
You might wanna double-check where you have put the sensors...I know that sound like me being an ass, but I did the exact same thing...I ended up plugging the bank 1 post cat O2 sensor into the bank 2 pre-cat spot. It's easy to do since the location of the plug itself is misleading. Anyway, check that out...Get the CEL read and look on here:
http://my.is/forums/f88/o2-sensors-cel-code-diagram-381832/

This is a great diagram I stumbled upon. If you are unsure if they are in the right spot, take a pic and send it to me through a PM. Good luck :)
 

·
Registered
Joined
·
143 Posts
Quick question, are the 02 sensors the same? Obviously, I know they are wired to read different things, but the physical o2 sensor (not the harness or where it clips). Basically, the threads on bank 1 pre cat were stripped, so I clipped the harness and wired it to the bank 1 post cat. I then installed this as the pre cat o2 sensor. Would this make any difference or not so much? The car runs and drives fine. However, the check engine light is on and the "trac off" light blinks every two seconds. I still have to wire in the o2 simulator but I just wanted to know if the swapping of o2 sensors might have made a difference. I figure the 02 sensors themselves are the same only the harnesses and what info the ECU pulls from them are different. Does anyone see a problem with this or should I be alright?
 

·
Registered
Joined
·
318 Posts
I hope someone can answer this or give any insight. Basically, I'm getting CEL for my cats, which are starting to go bad. I bought the O2 sim and it works great. My question now is what are the short or long term effects (if any) because of the O2 sim giving the car a Normal operating temp signal when warming up the car in the morning or from a cold start?
 
1 - 20 of 32 Posts
Top