Lexus IS Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I'm a proud new owner of a 2001 IS200 (LHD)

My car has a few issues i need to sort out:

1) ABS light always on and TRAC lights us every few seconds. I know it's probably an ABS sensor (or wire) but i don't want to start checking all of them. I went to pull up codes but the code reader got nothing (was a generic code reader). Then i saw i could do an "internal" ABS test, with the paperclip method. I tried with both the OBD2 port in the car and also the diagnosis port in the engine. I don't get it. Whenever i turn the ignition to ON, i get 3 LOUD BEEPS, ABS flashes just once and then all the lights on the dashboard start to light up like a Christmas tree. Not sure what i'm doing wrong here, please let me know what's the correct procedure...

2) Parking brake light always stays on - my center stop light is not working, might that be the case or is the switch in the handbrake kaput?

3) AC not working (only blowing hot air) - and i head a whirring noise from about behind the glove box every time i start the car (stops after 5-10 seconds). I had a similar problem with my other car, it was a stepper motor (the gears inside it actually), i'm thinking it might be the same here, but not sure where to start troubleshooting...

Other than that, car is great, once i get these fixed, i can start thinking about more power...
 

·
Registered
Joined
·
2,108 Posts
I'm a proud new owner of a 2001 IS200 (LHD)

My car has a few issues i need to sort out:

1) ABS light always on and TRAC lights us every few seconds. I know it's probably an ABS sensor (or wire) but i don't want to start checking all of them. I went to pull up codes but the code reader got nothing (was a generic code reader). Then i saw i could do an "internal" ABS test, with the paperclip method. I tried with both the OBD2 port in the car and also the diagnosis port in the engine. I don't get it. Whenever i turn the ignition to ON, i get 3 LOUD BEEPS, ABS flashes just once and then all the lights on the dashboard start to light up like a Christmas tree. Not sure what i'm doing wrong here, please let me know what's the correct procedure...

2) Parking brake light always stays on - my center stop light is not working, might that be the case or is the switch in the handbrake kaput?

3) AC not working (only blowing hot air) - and i head a whirring noise from about behind the glove box every time i start the car (stops after 5-10 seconds). I had a similar problem with my other car, it was a stepper motor (the gears inside it actually), i'm thinking it might be the same here, but not sure where to start troubleshooting...

Other than that, car is great, once i get these fixed, i can start thinking about more power...
3 = air mode servo.
2 = more than likely the switch. Or got unplugged some how.
1 = Go by an auto parts store. Most can read the ABS codes as well.
 
1 - 2 of 2 Posts
Top