Lexus IS Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
3,105 Posts
Discussion Starter #1
ok, i had my trac light flashing and the check engine light on, so i take it down to autozone and have them scan for the code problem. came up with po171 and po174. anyways, after he does this i start my car up and leave and the lights go out. should i still be concerned about the code problems even though the lights went off?
 

·
Registered
Joined
·
983 Posts
What were the codes named?
 

·
Registered
Joined
·
230 Posts
bigkahuna2187 said:
po171 and po174. anyways, after he does this i start my car up and leave and the lights go out. should i still be concerned about the code problems even though the lights went off?
OK quick question are you using a K&N air filter??

P0171 = lean 1st bank
P0174 = lean 2nd bank

and FYI this is common if your MAF sensor is dirty and the burn off wire is contanimated. At work we get alot of these codes after people clean their K&N filter due to over oiling it and the oil covering the MAF sensor OR they dont change their air filter frequently.
 
  • Like
Reactions: Nicademus323

·
Registered
Joined
·
589 Posts
Okay, from experience, when my check engine light comes on with trac flashing, it was caused because my gas cap was loose. So all i did was tighten it and everything went back to normal. Hope this helps.
 

·
Registered
Joined
·
230 Posts
osmosis said:
Okay, from experience, when my check engine light comes on with trac flashing, it was caused because my gas cap was loose. So all i did was tighten it and everything went back to normal. Hope this helps.
he already pulled codes.. IF it was the gas cap then he would of gotten

P0440
P0441
P0442
 

·
Registered
Joined
·
4,826 Posts
This has happened to me before as well. I had a CEL and blinking TRAC light, and then it just suddenly went away. I didn't think too much of it though because it never came back :lol:
 

·
Registered
Joined
·
771 Posts
yeah i had that happen to me to... it went away the next day.. but it came on again and has been on for about three weeks.. im guessing its a heat sensor
 

·
Registered
Joined
·
230 Posts
OK here's how OBD II works.. the computer remembers the speed, RPM ect when the code was created and the light turned on.. Now if it sees the same information 3 times but it did not commanded a error then the light turns off.. BUT given your P0171 My bet is that its going to come back here soon.. you still need to answer if you have a K & N filter.
 

·
Premium Member
Joined
·
6,292 Posts
Just a reminder, Auto Zone, PEP Boys and etc use a universal scan tools to pull check engine light codes. The trouble code you get will still have to be verified by the dealers scan tool to get a accurate reading of your troubled code.
 

·
Registered
Joined
·
3,889 Posts
are you sure you installed all the vaccume lines correctly? a vaccume leak AFTER the mass airflow sensor would allow unmetered air into the engine, causing it to run lean, thus causeing the computer to richen the mixture, and set a code. Or in your case two codes. A dirty mass airflow sensor can also cause this type of code.
 

·
Registered
Joined
·
3,105 Posts
Discussion Starter #14
its not running rich, its running too lean. or what about the tube that goes from the intake manifold to the crankcase. i recently took it off and put it back on for some stupid reason, could that be a problem?
 

·
Registered
Joined
·
230 Posts
bigkahuna2187 said:
its not running rich, its running too lean. or what about the tube that goes from the intake manifold to the crankcase. i recently took it off and put it back on for some stupid reason, could that be a problem?
Oh that did it I bet.. when it runs lean is when there is air that is bypassed the MAF sensor so the computer doesnt put enough fuel to compensate.. So if your PCV tube was disconnected then yes it will run lean.. Its common on toyotas esp when a hose breaks off or gets disconnected to see those Lean codes
 
  • Like
Reactions: chado

·
It's 5 o'clock somewhere.
Joined
·
6,017 Posts
Bump....i had this problem tonight. My check engine light came on and the trac off is blinking. I am going to take it to lexus, if it is something to do with the air filter and mafs, will it still be covered under warranty if I have an aftermarket short ram intake?
 

·
Premium Member
Joined
·
6,292 Posts
P0171 = System too lean, A/F lean malfunction, long or short term fuel trim. TROUBLE AREA: air induction system, gas leakage on exhaust, maf sensor, injector blockage, O2 sensor (bank 1, sensor 2), fuel pressure, open or short in circuit in O2 sensor (bank 1, sensor 2), lastly ECM. Have it checked out.
 

·
Registered
Joined
·
606 Posts
Okay, from experience, when my check engine light comes on with trac flashing I DON'T TAKE IT TO AUTOZONE
 
1 - 20 of 23 Posts
Top