Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
So just recently my car almost died on the freeway, lost power and somehow the power came back on and managed to exit. Upon exiting the freeway i pulled over turned the car off and unpluged the battery posts. plugged them back in and turned the car on everything was fine. 5mins away from my house my car just died on me. Tried turning the car on and it would crank but wouldnt turn over, so ended up getting the car towed to my house. Checked all the fuses the following day everything was up to par. checked all the grounds and everything looked good. checked the MAF looked clean not dirty. so ended up calling a buddy with a OBD II scanner, he came over and hooked it up and it would not connect to my car. he immediately said it was my ECU that was already screwed (he's a mechanic from toyota) which is y im panicking at the momment. so my question is do u guys think my ECU is done and need's replacement or could it be maybe my gas pump? I need y'all help ASAP please!:(
 

·
Registered
Joined
·
838 Posts

·
Registered
Joined
·
1,908 Posts

·
Super Moderator
Joined
·
19,540 Posts
Sounds similar to this thread below, the Op wasn't able to connect his scanner and the ECU would not fire up because wiring to one of the DBW sensors was grounded or shorted which prevented the ECU to function. See if you have your positive and ground at the OBD(DLC3) port. What does your security LED do with the key in the ignition? Does it keep blinking? That would prevent the immobilizer to deactivate and you would never get any fuel.

http://my.is/forums/f115/2001-is300-wont-start-turns-over-strong-449100/
 
1 - 7 of 7 Posts
Top