Lexus IS Forum banner

21 - 40 of 1447 Posts

·
Registered
Joined
·
56 Posts
when you first start up your car and depress the brake, is there a clicking sound? I have that on my front passenger side wheel. I thought it would be the brake pads. So i changed it with genuine toyota ones. It went away. Now its slowly but surely creeping its way back. I'm wondering if what you speak of are the bushings.

anyways. i'm at 99,385 miles to the odometer.
i have the same exact problem, so i'm wondering of the same question..... please direct me and ^^^ to the right direction. and i have about 96k on my 02. and afraid to hit the 100k mark cuz i still havent change the timing belt nor waterpump.....
 

·
Moderator
Joined
·
27,116 Posts
2001... I just crossed into the 100K club. No rough idle or anything like that...
 

·
Registered
Joined
·
447 Posts
91k on my 02, bought it aug 06 with 65k... will proly be around 96-100k when i go boost in a couple months... and im still on stock clutch water pump timing belt... the only thing is my cd player broke a couple days ago and my o2 heater went out (did my.is ecu remedy)....

and yes im changin my clutch before boost... changing everything when boostin :) i cant wait
 

·
Registered
Joined
·
491 Posts
01 just reach 81000 miles
 

·
Registered
Joined
·
368 Posts
01 with 66XXX miles equals to 107xxx km in canada
 

·
Registered
Joined
·
314 Posts
bought mine just over a year ago with about 77k.
now im right at about 99k.. all those trips back and forth from AZ to CA and up to the mountains with no problems at all
 
21 - 40 of 1447 Posts
Top