Lexus IS Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
Hey guys Im new to the site and I just bought a IS300 about a month ago.
Lots of plans for it but i pretty much got it for a steal, and you get what u pay for. The cosmetics are fine, BUT the body kit isnot a great fit and you can tell the did not use the original equipment to hang ot. Hopefully will fix or replace soon.
I am currently puttin money asside and tryin to decide wether to get the few minor exterioir problems taken car of, or start with the engine mods. I know i want either the SRT turbo kit, or the turbonetics kit. Not sure if i wannt to stick with A/T, or make the M/T switch yet. The only thing i Have done so far is the HKS catback
But I have another PROBLEM! :confused:

1. First the Speedometer needle quit moving, and the MPG guage, AND odometer when out too. Rest of the guages work though, any ideas?

2.) here come more probs! The traction control switch dosent seem to work and the light is always on.

3.) the ABS light also is always on, me an mechanic cant figure out why

4.)CEL light is on. i took it to autozone and the following codes came out:

a.)Cylinder 2 and Cylinder 5, missfire detected, i do have a tick but anybody got an idea why? I do know the motor was boosted by the preivous owner and the pistons had to be replace, could this = the cause?

b.) P0125, closed loop fuel ctrl insufficent coolant temp
-How do those two things even affect each other? Any ideas again?

c.) P0174 system too lean
- clueless, any ideas?
d.) Have a few for bank 2 o2 sensor and catalyst efficency but i got it on those.

I hate to have to ask these in my first thread but i want to get my car right. So anyhelp is appreciated, and is soon as this is dealt with there will be PLENTY MODS to come, so thanks everybody
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3 (Edited)
Welcome, sounds like you have quite the project ahead of you. Good luck.
yeah i noticed, thanks for the welcome though

Been reading old threads and found out what some of the problems are, my VSV was had absolutley no hoses goinig in to itjus tucked off to the side, hopin this knocks out most of the lights. Man,this site is great so far, thanks everybody!
 
1 - 4 of 4 Posts
Top