Lexus IS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
So i bought a fuel pump and it didnt come with these pieces i was gonna use the old ones but when i took the old pump of they got broke. Please help
135612
 

·
Registered
2002 Lexus IS300
Joined
·
725 Posts
Just tried looking those pieces up on a Lexus online parts catalog. No dice. You may have to try a local Lexus dealership to see if they can help track down those parts. Worse case is to return that pump you bought and maybe see if different brand pump will come with the pieces you need.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Just tried looking those pieces up on a Lexus online parts catalog. No dice. You may have to try a local Lexus dealership to see if they can help track down those parts. Worse case is to return that pump you bought and maybe see if different brand pump will come with the pieces you need.
Damn thanks for the help buddy
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
Ok so i bought the oem denzo pump with all the pieces and i got them but when i put the pump in and the new relay in it still isnt priming
 

·
Registered
2002 Lexus IS300
Joined
·
725 Posts
Ok so i bought the oem denzo pump with all the pieces and i got them but when i put the pump in and the new relay in it still isnt priming
Are you getting power to the pump while cranking the engine?

Side question:

does the security light go off?
 

·
Registered
2002 Lexus IS300
Joined
·
725 Posts
But when i crank it the light goes off
Oh ok that’s good. Check your pump connector to make sure it’s getting power while cranking. If it’s not, it could be a bad relay ( I think there are two if I’m not mistaken) and/or ignition switch.
 
1 - 11 of 11 Posts
Top