Lexus IS Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
I just got my speakers, amp and headunit installed at Fry's and they did a horrible job. I've been there twice and the problems still haven't been resolved...

Problems…
1.) I hear a constant whine when the volume is low
2.) My stock system had way more bass then what I have now
3.) My front and rear speakers rattle( they said they used brackets instead of baffles)

Basically my system sounds like shit….. heres what I got installed

Headunit: Kenwood KDC-MP928
Front Components 6 ½” Diamond Audio D661a
Rear Speakers 6x9 Diamond Audio D391i
Hifonics ZX4400 Zeus Series

Can someone tell me what the cause of these problems are?
 

·
Registered
Joined
·
112 Posts
1) your ground is bad. Check all of your grounds and redo them if needed.
2) Check your amps settings. Specifically Gains.
3) put some sort of foam tape behind the speaker. If it still rattles, its your door panel not the speaker.
4) dont EVER go to frys.
 

·
Registered
Joined
·
3,922 Posts
1. does the whine increase when you rev the engine?...pretty much your ground is bad.
2. Def. check your amp settings, they probably have it all the way down.
3. If the brackets is what is making the speakers rattle, then I would use the stock speaker brackets, which many, including my self, have done by ripping out the old speaker.

yeahhh pretty much what the guy above said lol
 

·
Registered
Joined
·
50 Posts
Discussion Starter #4
thanks for the help guys...

The whine doesnt increase when I rev my engine
Which setting on my amp do I check?
and they said they used brackets for spacers because the end of the front speakers would interfere with the window... they also said the baffle isn't neccesary (not sure if their right, im not knowledgeable when it comes to audio)
 

·
Registered
Joined
·
3,922 Posts
Check the gain on the amp

The best fitment is stock baffles that the stock speakers are intergrated to. If you want to, you can buy some stock speakers from the member sale/trade area and rip the stock speaker out of it and retain the stock baffle...

...I just confused you haha...
 

·
Registered
Joined
·
3,922 Posts
blackmagic168 said:
where is a good place to ground my system.. i get the whine too.. it gets louder when i rev my engine.

find a suitable place for the ground...I put my ground where my jack goes...and make sure you sand the paint off completely.
 

·
Registered
Joined
·
112 Posts
amp ground should be no more then a foot or two, yuo need to dremel away the paint around a bolt that goes directly into the chassis.
 

·
Premium Member
Joined
·
2,767 Posts
i put it in one of the holes that were already in the trunk frame, just sanded the paint away and hooked it up. Works great.
 
1 - 11 of 11 Posts
Top