Lexus IS Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter #1
i kno there are a lotta threads already about CEL. but i realli need to find the best solution here, hope u guys can help.

My Check engine light went on yesterday, so i went to Autozone this morning, got three codes: P0171 (twice) and P0174 (once). I did a search here and found out that it's "System too lean".

After that, i brought it to my mechanic. He told me that it's because the Oxygen/Fuel rate is too high (or something like that). He said he didn't know what exactly the problem is yet, so he cleared the computer memory to shut off the light. He told me to let him know when the light goes back on again, if it goes back on in 1 day or 2, then i can drop the car off. but if it goes back on in a month of so, then it's harder to fix...
either way he said it would take a lot of time bcuz he has to figure out what or which sensor is wrong.

I was hoping maybe u guys know what's going on here so i can have a clue and save him some time and save myself some labor cost...
i was planning on bringing it back to the dealer cuz it's a 01 with over 70k miles on it, it shouldn't be under ANY warranty.

thanx in advance
 

·
Registered
Joined
·
5,941 Posts
nu6lover said:
oh shoot, exact same problem there..
thanx Leo! +rep
btw i saw u again at 180
Yeah, I might be heading there this Friday. I didn't we had some mutual friends. Two of my good friends are going out with Jess and Sandy.
 

·
Registered
Joined
·
291 Posts
Discussion Starter #5
lambchop11078 said:
Yeah, I might be heading there this Friday. I didn't we had some mutual friends. Two of my good friends are going out with Jess and Sandy.
yea small world... i might be going there this friday too, there were a lotta girls last week haha
 

·
Registered
Joined
·
291 Posts
Discussion Starter #6
cleaned my MAF, reset the ECU and changed my air filter at the same time... it feels so smooth now, maybe it's just a mental thing but i will see
 
1 - 7 of 7 Posts
Top