Lexus IS Forum banner

21 - 23 of 23 Posts

·
Registered
Joined
·
8 Posts
Hello, I have a problem with my climate controls, my whole upper part of the center console is not responding, i checked all fuses and everything was fine, i also thought maybe something got disconnected in the back of the unit, so i took it out and all wires look good and plugged in. Im not sure where i can go after this point, any help or suggestions, thanks a lot

hey guy just got a dash (climate control part) from my friends car, he was generous enough to take it off and see if that was the problem on my car. after plugging up all the wires, the buttons still did not respond and the lcd screen was blank. any other ideas what can be wrong? anyone know what exact fuse controls the buttons,climate unit (i checked all the fuses i could, they all seemed ok, maybe I'm missing something, or ill just change the fuse just for the hell of it)?

help please
Did you get this fixed? Was the screen black or just frozen? One thing I've learned through all of this is that NO ONE is touching anything on my car that is not carrying enough ins to fix the damage. Apparently, there are a million and one ways to fry the nav screen.
 

·
Registered
Joined
·
1 Posts
This is an old thread but my solution/experience may (or may not) help others. I have an '06 IS350 with about 110K miles. It's exceedingly unpleasant outside (90+ F, very humid) and I had the same problem this AM - nav screen black, no buttons worked, radio did work. I disconnected the negative lead, verified fuses, drank a good IPA and reconnected the battery lead. After that, all is well. Nav screen works, buttons ok, A/C works!
 
21 - 23 of 23 Posts
Top