Lexus IS Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
So my driver side headlight would come on dim then flicker for a while then go out after a few minutes. Now it doesn't even turn on. I assumed it was a ballast problem, since the bulb was working. I bought a ballast off of ebay, and I installed it today.....2 hrs of frickin work and the headlight still doesnt work. How should I tackle the problem from here on out. I refuse to pay 800 for lexus to change my ballast, I already did this.

Huggi Bear
 

·
Premium Member
Joined
·
23,314 Posts
Its a bulb. HIDs dont have a filament like halogens thus they dont just "go out"
 

·
Registered
Joined
·
213 Posts
Same thing happened to me

Switch your bulbs around for like a week and see if the drivers side still works, that way you know for sure its your bulb
 

·
Premium Member
Joined
·
10,782 Posts
There is a thread about this already. Try to read your searches. I understand there is a lot of non related issues. But its in there. As for Jefferson's quote: I did the same thing. And its in a thread somewhere, I mentioned the same thing.

-Tom- is right as well.


Same thing happened to me

Switch your bulbs around for like a week and see if the drivers side still works, that way you know for sure its your bulb
 

·
Registered
Joined
·
1,883 Posts
you should always change out the cheapest part first when you're diagnosting any problems..replacing the bulb is much cheaper than replacing the ballast....
 

·
Registered
Joined
·
2 Posts
same thing happened to me. my headlight flickers for about a minute and then shuts off. i changed the bulb that wasnt the problem so i got a ballast and changed that. still with the new bulb and ballast my light has the same problem. i had some moisture in the light somehow when this started happening so maybe there is a shortage somewhere i just cant figure it out. its not getting the right power to the bulb so it shuts itself out. i might take it to lexus this week they said it would be about 50$ and a half hour to diagnose it
 

·
Registered
Joined
·
26 Posts
I have a similar problem too. Both of my headlights flicker even when the car is off. It seems to happen only after I drive through a small puddle (by accident). Seems like the splash deposits residual water under the hood somewhere that causes the electricity to flow where it shouldn't. It annoys the heck out of me... I am gonna do the searches, but it will be extremely helpful if someone who knows anything about this issue point us in the right direction.
 

·
Registered
Joined
·
77 Posts
went through that drama too..i bought the ballast from advanced had them installed and just wired it backwords then switched it and then they worked so check it out...the ballast work great and they were only like 70 a piece from advanced not 1300 from the dealer...hopefully you got a good one from ebay..good luck
 
1 - 10 of 10 Posts
Top