Lexus IS Forum banner
1 - 20 of 42 Posts

·
Registered
Joined
·
634 Posts
Discussion Starter · #1 ·
Well.... last night I offically blew a piston ring. Too much oil pressure + high psi turbo spike = blown motor. Well, on the other hand I just bought a brand new GTE shortblock and tt headgasket... I know it's basically a direct bolt-on but is there anything else I need besides the headgasket? Thanks!
 

·
Penetration Specialist
Joined
·
22,782 Posts
sorry to hear man. can't believe you were running 21psi on stock internals!! :eek:
 

·
Registered
Joined
·
634 Posts
Discussion Starter · #3 ·
Wino_II said:
sorry to hear man. can't believe you were running 21psi on stock internals!! :eek:
I didn't wanna run 21 psi... focking just spiked when everything was set @ 0. I probably didn't have the controller hooked up correctly. What a pisser.
 

·
Penetration Specialist
Joined
·
22,782 Posts
hchan said:
Wino_II said:
sorry to hear man. can't believe you were running 21psi on stock internals!! :eek:
I didn't wanna run 21 psi... focking just spiked when everything was set @ 0. I probably didn't have the controller hooked up correctly. What a pisser.
shoulda let me know in beantown. :-?
 

·
Registered
Joined
·
634 Posts
Discussion Starter · #5 ·
Wino_II said:
hchan said:
Wino_II said:
sorry to hear man. can't believe you were running 21psi on stock internals!! :eek:
I didn't wanna run 21 psi... focking just spiked when everything was set @ 0. I probably didn't have the controller hooked up correctly. What a pisser.
shoulda let me know in beantown. :-?
Yup... too late now... wish I remembered bout my boost controller.
 

·
Penetration Specialist
Joined
·
22,782 Posts
hchan said:
Wino_II said:
hchan said:
Wino_II said:
sorry to hear man. can't believe you were running 21psi on stock internals!! :eek:
I didn't wanna run 21 psi... focking just spiked when everything was set @ 0. I probably didn't have the controller hooked up correctly. What a pisser.
shoulda let me know in beantown. :-?
Yup... too late now... wish I remembered bout my boost controller.
good luck with everything...I may be going the GTE route soon also.
 

·
Registered
Joined
·
2,415 Posts
the GTE needs custom motor mounts to make swap possible....Youll love it as much as I do...awesome block....
-Matt
 

·
Registered
Joined
·
634 Posts
Discussion Starter · #8 ·
UnVme said:
the GTE needs custom motor mounts to make swap possible....Youll love it as much as I do...awesome block....
-Matt
custom motor mounts? I was never told that!! Where can I get some?
 

·
Mr. Negative
Joined
·
11,977 Posts
man hchan that sucks! Sorry to hear about the motor. Let us know how the block swap and all goes.
 

·
Registered
Joined
·
5,744 Posts
hchan said:
UnVme said:
the GTE needs custom motor mounts to make swap possible....Youll love it as much as I do...awesome block....
-Matt
custom motor mounts? I was never told that!! Where can I get some?
Sorry to hear about your engine bro, ask GTE about the custom engine mounts. He might be able to help you out.
 

·
Registered
Joined
·
1,796 Posts
if i remember correclty, when i was asking around your stock motormounts should work. I talked to trekster... I think about this, i could be wrong though but....


try ask the guys that have actually done the gte block only swap :D
 

·
Registered
Joined
·
634 Posts
Discussion Starter · #12 ·
I just got off the phone w/ [email protected] about a hour ago. He said our stock mounts could be modified to fit the gte block. We spoke briefly and made plans for a appointment in 2 weeks. If you MD guys wanna meet up while I'm down there let me know. Thanks!
 

·
Registered
Joined
·
1,254 Posts
Yea I know their has been a few people with stock motor mounts that were modified.
Jeff should take good care off you, and also look into getting the block checked for clearances been alot of blown gte blocks as of late.
 

·
Registered
Joined
·
11,891 Posts
its probably going to end up being one stock/modded, one custom
 

·
Registered
Joined
·
1,796 Posts
Fig said:
Going through the same build soon, was there ever a full detail? New GTE block should mount with the same GE mounts, GTE headgasket, and what about the oil pump?
I will find out soon, but it would be noce to have all the parts ordered.

Thanks, FIG


i'm sure you can use either one. the block should mount up no probs as long as the block is a superceeded one.
 

·
Registered
Joined
·
1,073 Posts
Kind of off topic but kind of related ... I tore down two motors today. One was a 2JZ-GTE (post 1998 JDM) the other was from a 2002 Lexus IS300. I noticed that the rods were identical. I remember some time ago that someone mentioned that the GTE rods were a lot stronger and looked thicker. Well, mine look the same. I wonder if Toyota has cheaped out on the newer GTE blocks? Hmmm. In any case, the stockers are gone.

The blocks for the 2JZ-GTE (post 98) and the GE are identical except for the oil squirters and one or two water inlet/outlets that are plugged on the IS. The oil pumps look very similar, but I did not put them side by side to check this.

Oh and WTF! The crank pulley bolt was a real mofo to loosen as was the intake cam, what's the deal here?
 

·
Premium Member
Joined
·
2,849 Posts
Everything and I mean everything will bolt right up. The only thing you need to do is block the two oil supply holes in the passenger side of the block for the stock twins and there is a 1/8 BPT oil pressure hole in front of the block in the drivers side that needs to be plugged as well. Other than that everything will bolt right up including both motor mounts.

I do not know why people speculate/misinform and say that things need to be modified and such to scare people away. That is just lame.


hchan said:
Well.... last night I offically blew a piston ring. Too much oil pressure + high psi turbo spike = blown motor. Well, on the other hand I just bought a brand new GTE shortblock and tt headgasket... I know it's basically a direct bolt-on but is there anything else I need besides the headgasket? Thanks!
 
1 - 20 of 42 Posts
Top